Question Zotac Gtx 1060 3GB amp edition shows artifacts

Jun 15, 2021
3
0
10
0
My gpu shows artifacts when clock speed/ temperature reach above certain level. I try to figure out what is the problem by looking at the board. It seems that the board is showing some water damage ( are those? Please advise) https://ibb.co/dK377qY << image. And the culprit most likely is these two thermal pads (https://ibb.co/vjL1DfH) and one seems to be missing. The gpu was sent for RMA because one of the fan wasn't moving. The issue occur after that and the warranty has already expired after i noticed the problem 😩. What should i do now? Please advise, thanks in advanced.
 

Eximo

Titan
Ambassador
Various oils and things in thermal pads and thermal compound. After many heat cycles it can come out. Also the solder paste used to attach the components in the first place. That might leave residue that only comes up after repeated heat cycles.

Clean the card, get new thermal pads and paste, and hope for the best.
 
Reactions: Shiji93

sydneyblue203

Honorable
Aug 2, 2014
1,727
46
12,190
116
Im not sure what your asking ? The card is out of warranty and needs repair. I would get a quote on what the repair would cost and see if its alot less then buying a new one . I suspect the fan died and the gpu overheated.
 
Jun 15, 2021
3
0
10
0
Various oils and things in thermal pads and thermal compound. After many heat cycles it can come out. Also the solder paste used to attach the components in the first place. That might leave residue that only comes up after repeated heat cycles.

Clean the card, get new thermal pads and paste, and hope for the best.
Sounds like it, much appreciated for the clarification!
 
Jun 15, 2021
3
0
10
0
Im not sure what your asking ? The card is out of warranty and needs repair. I would get a quote on what the repair would cost and see if its alot less then buying a new one . I suspect the fan died and the gpu overheated.
Sorry for the confusion, it just that i not sure what causes the artifacts and by looking at the board it looks like water damage and i was asking for clarification.
The fan was fixed after the GPU sent for RMA but the artifacts show up right after the RMA (after a few months) and when i noticed that, the warranty already expired. I will do what Eximo told me to do and hope it is only overheating issue.
Thanks for your response anyway.
 

ASK THE COMMUNITY