Question Zotac RTX 2070, bad performance in PUBG

Mar 7, 2019
14
0
10
0
i bought zotac rtx 2070 mini few days ago and i am disappointed how card perform in pubg even if i play on very low settings (only antialiasing and texutres are on medium, 1080p, screen scale 100%).
Frames sometimes drop to 48 on places like bootcamp, castle. Before i was using gtx 1050ti and frames never drop under 32 on bootcamp.
I really can't see that big difference in first moments when i land and try to pick up some weapon, its still very lagy.
Frames sometimes drop without reason in middle of game from 170 to 100. Playing from Europe with good connection ping 16-42 depends of server. Also unistalled old drivers with DDU from safe mode and installed latest one properly. One thing which make me suprise, settings on medium,high, low or very low no big difference in frames between them, on very low preset only +3 fps. Capping frames to 144 which is my monitor refresh rate also didn't help.
Temperature of cpu and gpu are absolutely fine. CPU Usage when playing is 38-51% , gpu usage 80-93%.

My pc specs are: MSI H110M Pro-VD, Intel i7 7700, 16 GB DDR4 2400 (dual channel 2x8), SSD, HDD, monitor is ASUS VG248QE connected via Dual Link DVI Gold Plated Cable. Also i changed PSU. New one is BeQuet System Power B9 600w 80+ Bronze. I know pubg is very bad optimized game but frame drops on hotspot like Bootcamp are too big. What could be a problem? some people told me, maybe is a cpu bottleneck?

Edit: After upgrading gpu i recognize cpu clock is not anymore on stock speed 3.6GHz, now cpu working from 3.9 ghz to 4.19 GHz
 
Last edited:

MetallicMonk

Upstanding
Feb 16, 2019
249
28
240
6
Any possible malware on your system?
Tried clearing CMOS and going through BIOS settings?
Try disabling onboard graphics.

Run DDU again and uninstall intel drivers as well as NVidia.

For future posts, try and break your post into paragraphs. It's really hard to read. That's probably why no one has replied until now.
 
Mar 7, 2019
14
0
10
0
Any possible malware on your system?
Tried clearing CMOS and going through BIOS settings?
Try disabling onboard graphics.

Run DDU again and uninstall intel drivers as well as NVidia.

For future posts, try and break your post into paragraphs. It's really hard to read. That's probably why no one has replied until now.
I clean pc very often with spybot search & destroy, adwcleaner and i unistalled drivers twice with DDU from safe mode, than installed again with "clean install" option in nvidia installer.
Today i reinstallad the game again and gpu/cpu usage changed but i set ViewDistance in game to ultra, because i read that option is more cpu demand.
GPU usage is 60-80% and cpu 37-60% but microstutters are still there.
 

ASK THE COMMUNITY

TRENDING THREADS