Question 100% cpu usage when loading up some games

Arbiter051

Reputable
Mar 28, 2016
222
1
4,685
0
9900Kf not oc and MCE is turned off
Gigabyte z390 Aorus Pro with latest Bios
Msi Gtx 970 non oc (1070 died. Waiting for them 3000 series cards nvidia :D)
32gb Corsair LPX Ram @3000mhz
850W Corsair PSU Gold Certified 80+
850Evo 500gb Which has the operating system
860Evo 1TB is loading the games
Seagate 1TB for general Storage
Windows is fully up to date 1909
I use Bitdefender free
Asus 144hz monitor
I run MSI afterburner, but only to control my fan curve, nothing else.

Hi there, when loading up certain games, my cpu seems to hit 100% for a few seconds and then come back down. I have dealt with this problem for almost a year on both this system and my older system with a 4790 and my gtx 1070 (I will miss this card) with Overwatch. This issue only seems to happen when starting up the game. When finishing a match my cpu also seems to spike a tiny bit in temperature ( haven't checked the cpu usage when finishing a game but I assume it is spiking because my temps spike from 48-50C to 57-58c for a second or 2), but not as bad. Early on in dealing with this issue, I found that closing and then opening MSI after burner again seems to stop Overwatch from doing this. However this as been hit or miss since over the course of Overwatch updates. Overwatch recently started doing this again and the closing/opening MSI after burner trick doesn't work.

I recently started playing Halo Reach and noticed when loading up my campaign, my temps were spiking to the low 60s C, when normally they are in the mid 50s C. When the MCC loads up in steam, the usage spikes a tiny bit, to about 30% cpu and then back to normal. But when loading up my campaign or when a loading screen happens, my cpu spikes to 100% till the loading screen ends (so usually 2-5 seconds).

I have tried closing everything, nothing running in the back round except for steam, the game and Bitdefender (outside of Microsoft stuff) but this still happens and it is just the game spiking, nothing else. I have scanned for malware with Hitmanpro, Malwarebytes and Emsisoft toolkit, but nothing, computer is reported as clean. There is nothing running I haven't seen before, I haven't made any recent changes and everything is up to date. I have tried all different settings with the game as well.

Turning on vsync, turning it off. Unlocked frame rate, locked 60 fps. GRaphics on highest and lowest. Nothing I do fixes it. I have been playing the game for 3 days and I am not sure if this just started or has been going on for all 3 days. The other thing is the game runs great, uncapped FPS I can get almost 300 and it never goes below 60/59fps if I cap it at 60, no stutters or anything of the sort. I also recently completed DS2 SOTFS and when loading the game or loading in from a bonfire, that game never did this 100% cpu issue, nor does Diablo 3.

I am looking for any guidance on if this is a known thing with some games or if anyone can just shed some light on the subject. Thank you :D.
 

Arbiter051

Reputable
Mar 28, 2016
222
1
4,685
0
is 100% cpu usage during game loading issue?
if it would be 50%, game would load twice as slow
if u doing something in background where u need some free resources, u can reduce cpu threads for your game, this will reduce max cpu usage game can utilise
https://www.thewindowsclub.com/processor-affinity-windows
The reason I ask is because it only happens in a few games. I am just unsure if this is actually a known issue with those games and/or issue in general that needs to be fixed. Also doesn't help that I can be paranoid about temperature's heh. It seems weird that with Overwatch, turning off and back on MSI afterburner fixes the issue, but with Halo it doesn't. It also doesn't always fix the issue with Overwatch either, it is hit or miss.

But I mean is it an issue? or is it not an issue and it is normal what I have experience? Sorry if these are dumb questions.
 

ASK THE COMMUNITY

TRENDING THREADS