Question 2nd external gpu wont display

merrickman2003

Reputable
Apr 10, 2018
6
1
4,515
0
So I'm trying to do a 5 monitor setup, my RX 5700XT only has enough ports for 4 so I got an ASUS Radeon HD 6570 to help me out.

Tried installing drivers through device manager, windows update, the old catalyst thing AMD used to have, nothing works. I also tried some kind of crimson thing that was beta to see if it'd work but it still doesn't.

Pretty much only works when my main GPU is disconnected, it'll display really low resolution so I know its almost definitively a driver issue. I checked device manager and it shows up, has no warning icon just the same one as my 5700XT, so device manager at least seems to think it works, also the fan is on at all times so it's getting power.

Read somewhere it might not work cuz I'm using Windows 10 and it's not supported but there's a tab under the Radeon website that shows Windows 10 (64 bit) so I assume it should, kinda stuck now though... is there any way to fix it?

edit:
Just checked device manager, it's telling me "no driver files are required or have been loaded for this device" whenever I check driver details

Specs
Radeon RX 5700XT - main GPU
Radeon HD 6570 - hopefully soon 2nd GPU
i5-9600KF
16gb 3000MHz DDR4
650W Corsair PSU
 
Last edited:

merrickman2003

Reputable
Apr 10, 2018
6
1
4,515
0
Update:
View: https://www.youtube.com/watch?v=C6BCNAEpdX0
using this video I'm able to install the drivers for my second GPU, which doesn't work with the new radeon software, but by doing that it uninstalls all AMD drivers.

Basically what was wrong is that windows tends to automatically install drivers for a lot of devices, but the drivers they chose for the gpu are trash and dont work, so I had to disconnect from the internet and wipe everything gpu wise, and everything pretty much worked after doing everything the video said.

After doing this I reinstalled my 5700XT drivers and by doing that it automatically deleted "old" gpu drivers (the ones I literally just downloaded), so back to square one. Tried wiping everything and then just installing the new radeon drivers before the 6570 ones, it just automatically gave me the crap drivers that Radeon automatically downloads.

Is there a way to stop Radeon from deleting old drivers when installing new ones?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS