Question 4790k core speed drop help

Feb 26, 2020
3
0
20
0
Win7 64.
Pentium 4790k @4.6 ghz,
Gigabyte GA-Z97-D3H
OC 4.6 ghz steady but drops and stays @ 4.0 ghz under moderate stress. Cpu cooling Noctua, temps fine. BIOS Power management ... C1E, State support and EIST all diasabled.
Win7 Power plan High performance. I have the BIOS Turbo Boost disabled but XTU shows Turbo Boost Enabled. Is BIOS not saving? Thanks for your help.

Images
XTU
https://imgur.com/YqMR0cI
View: https://imgur.com/0f9n0T9


BIOS
View: https://imgur.com/LZyKv75

View: https://imgur.com/kspBKXO

View: https://imgur.com/WvPdedQ

View: https://imgur.com/TXNVY4a
 

Darkbreeze

Titan
Moderator
First, before anything else, make sure your BIOS is up to date.

Turbo boost needs to be ENABLED for boost speeds to work. Otherwise it is just going to run at 4Ghz, because that is the base clock speed. Turbo boost should not be disabled when overclocking on Intel platforms from at least Haswell forward. Further back even than that if I remember correctly, but it's been a while since I've worked on a Sandy or Ivy bridge system for the purpose of overclocking.

Set the main multiplier to 4Ghz. Set the boost clock multi for each core to 4.6Ghz. Don't set it to sync all cores. Leave the C-states and Intel enhanced speed step enabled. Set the Windows power plan to performance BUT change the minimum processor power state to 8%.

That will allow the system to automatically range core frequency anywhere from about ~800mhz to 4.6Ghz based on load. It allows cores the opportunity to "cool" when they are not needed, and that not only helps reduce the package temps in most situations but likely will reduce specific core temps when doing anything that is not demanding an all core full load. It will likely increase the lifespan of the CPU as well by helping to protect it from thermal degradation known as electromigration.

That is one way anyhow. There are multiple variations on a theme but years of overclocking have led to those conclusions for me.

Lot's of good information here:

https://www.overclock.net/forum/5-intel-cpus/1411077-haswell-overclocking-guide-statistics.html
 

Darkbreeze

Titan
Moderator
Try enabling turbo boost AND setting the CPU clock ratio to 46. Then, set all the C states to Auto. Set Intel speed step to enabled. Set the power plan in control panel to Performance but set the minimum processor power state to 8% and leave the maximum to 100%.

Try it, and see what happens. It should drop the CPU frequency to about 800mhz at idle and allow the CPU to ramp up to 4.6Ghz under a load but should NOT cause all cores to automatically go to 4.6Ghz, only as needed. There is no need for disabling the power saving features. The amount of time it takes the CPU to react to load conditions is in terms of milliseconds, so it's far faster than you could ever notice or be aware of. Certainly too fast to have any effect on performance from an awareness perspective. Be sure to set the maximum turbo boost frequency for each core to 4.6Ghz as well, otherwise it will limit itself to whatever it is set to.

Honestly, that guide I linked you to is probably about the very best Haswell overclocking guide that exists. Far more complete and accurate than anything you are going to find on Youtube.
 

ASK THE COMMUNITY