[SOLVED] 5.1 / 7.1 audio tracks turned into stereo garbage with clipping

Jan 28, 2021
94
1
535
0
After doing dome extended hardware tests and analyzing files in audio editors, it is obvious to me, that the poor sound experience that I have with some video files is due to my operating system mixing multiple tracks with awful merging result into plain stereo

Long story short: 5.1 / 7.1 audio tracks attached to video files look absolutely normal in audio editors - but when played and recorded with the record-what-you-hear method they showcase an extreme clipping on the waveform. And this stunning discovery (thus concussion) was done after me first having done some extended auditory test and thinking, that it had to do something with the way too new / sophisticated codecs and my old inadequate / old hardware; with some sot of lack of compatibility. But having an old external 5.1 sound card, new integrated 7.1 sound card, old wired stereo headphones, new wireless stereo headphones used with wire and with USB Bluetooth transmitter, old stereo system with loudspeakers - I took time and tested various (stereo) hardware configurations (i.e. methods of connections). And conclusion was always the same: 7.1 is garbage or sometimes does not even play at all (showing just a single video frame in the player) while some 5.1 tracks are bad but sometimes / somewhat acceptable. But as I said the what-you-hear shows me more than clearly that I am not imagining things and there is a profound difference between 7.1 and 5.1; and that also 5.1 as standalone samples look bad (like extreme cases of music destroyed with loudness war)


And so the question is: what is happening here?


I am running Windows 10 Enterprise 20H2 19042.746 on Gigabyte X570 Aorus Ultra rev. 1.2 motherboard. I never had problem with stereo audio tracks while this with 5.1 / 7.1 I have noticed only recently after buying those new stereo headphones. At first I thought that it was these new piece of hardware, that it had problem with playing some frequencies- but then I also checked my other hardware and the issue was still present (only heard in a much less profound way as those headphones have great noise isolation and are somewhat high-end)
 
Jan 28, 2021
94
1
535
0
(...)
And so the question is: what is happening here?
(...)
What was happening was the fact that the culprit from the get-go was that one videoplayer that I used


Because some time ago in the Media Player Classic I tested positively options available in it at

Options > Internal Filters > Audio Swicther > Enable build-in audio switcher filter
Options > Internal Filters > Audio Swicther > Normalize


At that time I set up optimum values and forgot about them. And as it turns out there is an hugely profound difference between using them for listening to stereo music and using them for watching movies with surround sound (at least on a stereo hardware): the first is usable and the second is unacceptable


And this is how I once again in my life wasted hours on coming to a conclusion, that there is no good alternative for using normalization option available in the software of my external sound card (which no only is better in terms of sound quality but also because I have to turn it on and off constantly - thus remembering that I am using it)
 

ASK THE COMMUNITY