Question 60fps but it's not?

Amddefector

Great
Sep 5, 2020
155
8
85
0
Good day.

Having a problem with a certain game.
Fps counters say 60fps but it's not what I'm seeing on screen. At a guess it's more like 30fps or less. I thought maybe display or hdmi cable but it's only the one game all the rest are fine. I don't understand why game bar and evga app are reporting 60fps?

Thanks.
 

Amddefector

Great
Sep 5, 2020
155
8
85
0
What is the game?
What is your system specs & monitor resolution / refresh rate?
What makes you think it isn't running at least 60fps, while it does on others (what is it doing)?
Hi thanks for the reply.

I have
Ryzen 7 2700x
Asus Rog strix b450f board
16gb Corsair vengeance pro 3200
Evga rtx 3070 ultra xc3 gaming
Kingston 1tb m.2 drive
Integrator 750w bronze PSU

Resolution is 3840x2160 60hz

The game is snowrunner

The gameplay isn't smooth. It's laggy very laggy. What I'm seeing reminds me of when I plugged my 4k TV into my gtx 1050ti and tried to play GTA V @4k with all the settings cranked up and and got 20fps.

Other games like shooters and racing Sims all perform great at the same Res with ultra settings. Even cyberpunk 2077 with RT on is a lot better.

What I can't understand is the game being so laggy, how can it be running at 60fps.

I've got the evga frame limiter set to 60fps to prevent screen tearing but that don't seem to effect any other games either.

Thanks.
 

tecmo34

Administrator
Moderator
It sounds like more of a game specific issue versus a system issue, which is always better.

Have you tried uninstalling Snowrunner and re-installing it? It could help with a corrupt file or something in the game causing it to be laggy.

Have you tried playing with the settings, not going all out full-eye candy to see if it runs better?

Your system is well over the system recommendations, so it should run smoother, which makes me thing it is the game file itself since even Cyberpunk 2077 runs well.

  • CPU: Intel i7-8700 3.2 GHz / AMD Ryzen 7 2700 3.2 GHz
  • RAM: 16 GB
  • OS: Windows 7/8/10 (64-bit)
  • VIDEO CARD: 4 GB, GeForce GTX 970 / Radeon RX 580
  • PIXEL SHADER: 5.1
  • VERTEX SHADER: 5.1
  • FREE DISK SPACE: 20 GB
  • DEDICATED VIDEO RAM: 4096 MB
 

Amddefector

Great
Sep 5, 2020
155
8
85
0
It sounds like more of a game specific issue versus a system issue, which is always better.

Have you tried uninstalling Snowrunner and re-installing it? It could help with a corrupt file or something in the game causing it to be laggy.

Have you tried playing with the settings, not going all out full-eye candy to see if it runs better?

Your system is well over the system recommendations, so it should run smoother, which makes me thing it is the game file itself since even Cyberpunk 2077 runs well.

  • CPU: Intel i7-8700 3.2 GHz / AMD Ryzen 7 2700 3.2 GHz
  • RAM: 16 GB
  • OS: Windows 7/8/10 (64-bit)
  • VIDEO CARD: 4 GB, GeForce GTX 970 / Radeon RX 580
  • PIXEL SHADER: 5.1
  • VERTEX SHADER: 5.1
  • FREE DISK SPACE: 20 GB
  • DEDICATED VIDEO RAM: 4096 MB
Hi I have re installed the game but it remains the same. I have tried lower settings and even lower Res but it doesn't change the games performance at all. Must be the game itself as you say.

Thanks for the help.
 

ASK THE COMMUNITY

TRENDING THREADS