Question 9900k usage spikes during gameplay, lags

EtherBreather

Reputable
Jun 7, 2017
8
0
4,510
0
Rig- 2080ti, 9900k, 32gb of ram, 1tb ssd, connected to g sync 1440p monitor

Firstly, I have been working on this for the last two days and I have absolutely no idea what's going on, idk if it's a CPU issue, a mobo issue, gpu, ram, I have no idea. The reason why I am starting a thread here is because I notice a CPU spike that results in a noticeable lag spike in game.

I updated to windows 10 version 2004 about 2 days ago. I instantly noticed a problem as my computer blue screened as soon as it hit the desktop, right after updating. I noticed weird things like the blue circle that signifies something is loading, would just freeze. After booting up some games, I noticed a weird stutter that I never noticed before. I tried to reinstall the gpu driver using DDU which didn't do anything to help. After this, I decided to revert back to version 1909.

Fast forward to today and I'm at my wits end. Reverting to 1909 did NOT fix the problem and nothing I've done has fixed it. Things I've tried: change all in game settings to low, removed OC from CPU and GPU, reverted all bios settings back to default, reinstalling windows, remove the gpu and reseat, tried to test the CPU graphics but the fps was too low to test, removed secondary SSD, completely reinstall every driver that you install when you first boot, capped frames below my refresh rate, completely swithced out SSDs that booted windows.

When using afterburner and rivatuner, I notice that as soon as a grab this ladder in the game Visage, I get a CPU spike that drops my framerate and produces a very annoying and noticeable lag. This isn't the only area, the lag spikes happen when walking in random places and turning the camera. It is also not the only game that does this as I notice it in GTA V mostly when turning the camera.

I ran a userbenchmark for the heck of it and got the results you would expect from a rig like mine.

Can someone please help me diagnose what the heck is going on?
 

EtherBreather

Reputable
Jun 7, 2017
8
0
4,510
0
Temps are all fine. Have not tested ram, recommend a program to do so? Cpu cooler is the Corsair h series, the one with 2 140mm fans on the rad, not sure if the exact model number ATM
 

EtherBreather

Reputable
Jun 7, 2017
8
0
4,510
0
Ahh yes that's correct. So unfortunately memtest86 passed, I say unfortunately because the mystery continues. It's such a weird problem, it happens at the same place in the same game, never fails. I did mention that it happens in other games but those are more or less random. As soon as I click the button to grab the ladder, it stutters, CPU spikes, fps drops by like 40, then he grabs the ladder and it's fine. When you reach the top it starts to seemingly random stuttering except I've narrowed another stutter trigger to an open door that you pass through.

It's strange to me that it's so repeatable. I remember being told/hearing/reading that a repeatable issue is usually software and random strange issues are usually hardware? Is this true in most cases?

How could my situation be software when I've completely swapped out SSDs? But if it's not software, why am I passing all the tests?
 

ASK THE COMMUNITY

TRENDING THREADS