Question Acer Nitro N50-600 RAM upgrade gone wrong

Jan 7, 2022
2
0
10
0
For a christmas gift to myself I thought I'd upgrade my PC's ram from the included SK Hynix DDR4 8GB 2666mhz ram to the same type but 16GB. I first tried putting the new ram in the other 3 available slots, which just led to the PC saying I still had 8GB. After that I tried swapping the old ram for the new, which gets me to where I am now: the PC no longer shows any video and gets stuck on a loop while booting. (imgur video and closer look at the inside here) Since then no matter what RAM or combination I have in I get the same result. This was my first time doing something like this so any help would be much appreciated.
 
For a christmas gift to myself I thought I'd upgrade my PC's ram from the included SK Hynix DDR4 8GB 2666mhz ram to the same type but 16GB. I first tried putting the new ram in the other 3 available slots, which just led to the PC saying I still had 8GB. After that I tried swapping the old ram for the new, which gets me to where I am now: the PC no longer shows any video and gets stuck on a loop while booting. (imgur video and closer look at the inside here) Since then no matter what RAM or combination I have in I get the same result. This was my first time doing something like this so any help would be much appreciated.
Not all ram will work with all mobo's.
Not all ram sticks will play nice with other ram sticks.

Send the new ram back and then go here and run the scanner.

Look for a 2x ram kit.

Crucial
 
Jan 7, 2022
2
0
10
0
Not all ram will work with all mobo's.
Not all ram sticks will play nice with other ram sticks.

Send the new ram back and then go here and run the scanner.

Look for a 2x ram kit.

Crucial
Should the computer not be working even if I'm just putting the original RAM back in it's original slot without the new ram installed at all?
 
Should the computer not be working even if I'm just putting the original RAM back in it's original slot without the new ram installed at all?
It may require a bios clear to work again.
Use google for the how to.

It's possible you pushed some crud into the slot so look close.

Hope you were not swapping with the psu connected.
 

ASK THE COMMUNITY