Question Are these components compatible with each other?

Jun 29, 2022
12
0
10
0
I just ordered the following components but the assembly guy said that the GPU and PSU are not compatible with the motherboard, please help me.

Processor Intel Xeon Sliver 4214 12C/24T
Motherboard Intel Server Board S2600STBR
CPU Cooler Intel CPU Cooler 300C
RAM Hynix 64X1 Ecc Memory 2666MHz 64GB
GPU ASUS GT730 2GB DDR5
Storage Samsung 2TB 870 Qvo 2.5 SSD
PSU Deepcool PM750D 80+ Gold
Cabinet Phanteks Enthoo Pro Typec(Black)
 

egda23

Estimable
Tbe PSU could be problematic.
This motherboard supports 2 CPUs, each with it’s own 8 PIN power connector.
Moreover, it needs the standard 24 pin ATX power connectors, BUT it also has a 4 pin 12V Aux power in ( no idea what for).
Clearly this PSU does not have all these connectors.
https://www.intel.com/content/www/us/en/support/articles/000024504/server-products/server-boards.html
 

Eximo

Titan
Ambassador
Indeed, I looked at the wrong board. It is a dual socket. That is a bit problematic.

You could get adapter cables to get additional 8-pin connectors, but it would be simpler to spend more on a larger PSU that has multiple CPU 8-pins.

Additional 12V to board is usually for powering the PCIe slots. These days they use a 6-pin PCIe connector. (In the odd case that you installed like 4 75W cards in the slots and expected all that power to flow through the motherboard traces)
 
Jun 29, 2022
12
0
10
0
Why did your team say that ? Ask directly.
Their reason completely escapes us
This is what they say, no data about the compatibility.
The Graphic Card Mentioned by Yogesh Asus GT730 2GB DDR5 is Desktop level GPU, which this processor and Motherboard does not support, we have tested this ASUS GPU is working with desktop only. NVIDIA Quadro T400 4 GB Graphic Card is compatible with this board.

Board specifications
: https://ark.intel.com/content/www/us/en/ark/products/192612/intel-server-board-s2600stbr.html
GPU: https://www.asus.com/Motherboards-Components/Graphics-Cards/ASUS/GT730-SL-2GD5-BRK-E/

I just wanted to know why it is not compatible if it is the case.
 

ASK THE COMMUNITY