• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question ASrock b450m-hdv rev 4.0 not posting with ryzen 3100

Jun 22, 2020
3
0
10
0
I have a rev 4.0 ASrock b450m-hdv that isn't posting with my Ryzen 3100 chip. I threw in an older 9600 CPU and it boots fine, I've tried different RAM and it still won't post with the 3100.

No beeps from the pc speaker so I have no idea what the issue is. Took the CPU back thinking it was faulty and it posted fine on the stores test bench. Anyone have any issues like this, is the board faulty?

Bios is listed as 3.70 which is higher than the bios required on the ASrock website for the board. Box says Ryzen 3000 ready.
 
Jun 22, 2020
3
0
10
0
ASRock B450M-HDV - BIOS Download Page
Reverify the BIOS version as this page only lists BIOS version 3.3 (guessing it actually says 3.1)

ASRock B450M-HDV - CPU Support List
Required BIOS version for that CPU is version 3.3

Not sure what older processor you used as there is no "9600" listed on the CPU Support List.

-Wolf sends
Nope, bios is listed as 3.70. I see the CPU isn't listed, but it works fine and is a very early AM4 CPU. I was also a little confused when I saw the latest BIOS listed on the site as 3.30. I even tried flashing but it wouldn't see the bios file on my USB stick (FAT32 format as per mfg instructions).

Hopefully the picture of the bios screen shows up.
 
Nope, bios is listed as 3.70. I see the CPU isn't listed, but it works fine and is a very early AM4 CPU. I was also a little confused when I saw the latest BIOS listed on the site as 3.30. I even tried flashing but it wouldn't see the bios file on my USB stick (FAT32 format as per mfg instructions).

Hopefully the picture of the bios screen shows up.
Do you have a dedicated GPU ? 3100 doesn't have one. Your old CPU must be AMD A8-9600 which does have IGPU.
 

ASK THE COMMUNITY

TRENDING THREADS