Question ASRock H310M-HDV/M.2 BIOS Issue

Apr 20, 2019
1
0
10
0
Hello all,

I am running the latest BIOS Version 4.0. The issue I am having is the boot order automatically changes when I insert a bootable USB drive. So, my next boot automatically goes to whatever is on the new boot drive (ie, Macrium Rescue, Android OS, etc).

Now, on all of my other mobos, I always had to hit Fxx to go to the boot menu and select the newly inserted USB drive or go into the BIOS and manually change the boot order.

I looked through the BIOS and I can't see any option to stop this behavior. So, does anyone have a solution? Thanks in advance!

cor
 

Lutfij

Titan
Moderator
You should see an option in BIOS to disable USB boot devices or external devices. You should also have the option to select the primary boot device as Windows Boot Manager. The manual uploaded on ASRock's support page might not be exactly what you're seeing.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS