• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question ASRock x580 phantom gaming 4 won't boot

Apr 12, 2020
4
0
10
0
Specs
ASRock x580 phantom gaming 4
Ryzen 5 3600
2 x Corsair vengeance lpx 3600 MHz, DDR4, 16 gb
Gigabyte rtx 2060 grafics
Evga 550 g3 gold psu

Just built this computer, went through the will not boot sticky and reseated and plugged in the cpu. Currently and getting this pattern from the LEDs.
Cpu and dram led on,
Then cpu and boot
Then the cpu light flashes, goes out. Then the pattern repeats. Any ideas?

Edit: fans are all working.
 
Last edited:
Apr 12, 2020
4
0
10
0
Edited post for psu, and tried one stick of RAM and got the same pattern.
tried the other pci-e slop for the graphics card and d got the same issue.
 
Last edited:
CPU power connector (photo of your X570 board shows one 8 pin) connected from PSU to mainboard (CPU ATX12V) via correct modular cable that came with whatever PSU you are using?

Remove power cord, remove BIOS battery, drop down to one ram stick in recommended slot, hold power button down for 10 sec, perhaps remove GPU entirely, reinsert battery and power cord and see if the mainboard can at least then recognize that it has no graphics adapter, which is actually a 'sign of life' from CPU.

At some point, if no progress, you will want to very carefully remove CPU, verify correctly /oriented/ seated with no bent pins, etc... (The written logo of the CPU's heat-spreader faces kind of sideways compared to Intel mainboards, with the little gold triangle pointing up toward the PS2 mouse connector/USB ports on rear IO panel..) If you know all this, sorry, just double checking!
 
Apr 12, 2020
4
0
10
0
No, thanks for checking, and yeah the cpu should be seated correctly in the direction you described, I'll try taking out the bios battery I guess.
 
Apr 12, 2020
4
0
10
0
Well. I tried 1 stock of ram in all slots, no change, and tried just romovjng the gpu and no change as well. Makes me think it light have something to do with the cpu? Not really sure
 

ASK THE COMMUNITY

TRENDING THREADS