asus 1080 troubles

Ian_1979

Reputable
Aug 20, 2016
7
0
4,510
0
Hi everyone. Hope this hasn't been answered before but after installing my asus strix 1080 last night i had nothing but problems....until that is this morning when everything is running fine at the moment. Anyway what happened was I had a gtx 670 installed that i replaced with the 1080. Upon booting at first it couldn't get passed the ROG bios boot screen. After I while it got passed that but froze at the windows 10 logo but then wanted to repair itself which pretty much formatted windows and started again. But it would keep doing this over and over again.

So a mate said is your ROG motherboard auto overclocked via bios or the ai suite. My answer was yes. Anyway after turning that off and loading optimised defaults, i was still getting the same problems. By this stage id formatted about 5 times with windows 8.1 could get into windows sometimes but installing gpu drivers would make it freeze. Also getting to the stage on installing windows update to 10 froze also.

I gave up and went to bed with the intention of phoning up the pc store and asking for help and maybe a possible return of the card.
BUT getting up this morning I've had no troubles what so ever. Everything including games run like a dream.
So does this mean the overclocking was causing the problems and the pc needed to be shut down completely for a few hours? If so why because my passed gpu had no problems with the overclock.
Maybe not enough juice from my psu?

If anyone can clear up my confusion i'll be grateful.
Thanks and system specs below
3570k (did auto oc to 4.5 or 4.8 i forget exactly again using ai suite II)
asus maximus v formula
gskills ddr3 ram (i forget the speed if needed i'll find out)
ssd via sata for boot and 3 hdds
using onboard sound
psu antec 900watt bronze
 

Ian_1979

Reputable
Aug 20, 2016
7
0
4,510
0

Thank you for the reply. Yes I have the latest BIOS and Drivers from Asus. I was curious so I put the overclock back on again. No problems. Windows 10 must have just hated the new card. I'd even removed the old drivers with the old card in it before hand
 

ASK THE COMMUNITY