Question Asus B350-f M.2 970evo 500gb

UberOriginal

Reputable
Aug 6, 2016
16
0
4,510
0
Asus B350-F updated bios, m.2 970 evo 500gb. I installed windows 10 with just a usb after installing the ssd. In the bios the ssd showed up immediately in the boot disks page, but in the page with all of the sata ports, and the m.2 port, the m.2 port says empty. Again, I have windows installed, went perfectly without a hitch, installed all of the latest drivers from ASUS and AMD, but when I go back into BIOS the port still says empty. Am I missing out on features or bandwidth because the m.2 is not being recognized properly? It also has the latest firmware.
 
Asus B350-F updated bios, m.2 970 evo 500gb. I installed windows 10 with just a usb after installing the ssd. In the bios the ssd showed up immediately in the boot disks page, but in the page with all of the sata ports, and the m.2 port, the m.2 port says empty. Again, I have windows installed, went perfectly without a hitch, installed all of the latest drivers from ASUS and AMD, but when I go back into BIOS the port still says empty. Am I missing out on features or bandwidth because the m.2 is not being recognized properly? It also has the latest firmware.
That's usual, you'll see the M,2 drive as " UEFI on Samsung 970......." in BOOT order.
 

UberOriginal

Reputable
Aug 6, 2016
16
0
4,510
0
Not talking about the boot menu, the menu that shows what drives are connected, the name of the menu escapes me, I'll try to find it when I get back home. It's the screen that shows all of the possible disk connections, ie. SATA_1 SATA_2 - through- SATA_6, and last on the list is the M.2 slot, every single one says empty, including the m.2 970 evo. I see there is a new BIOS this week that mentions M.2, I will see if that fixes it in a few hours.
 

UberOriginal

Reputable
Aug 6, 2016
16
0
4,510
0
Flashed BIOS to 5216, no difference. The menu I was b.c. referring to is under Advanced\SATA Configuration. Has SATA6G_1(Gray), SATA6G_2(Gray) etc, until M.2(Gray) and every one of them says Empty. Under: Boot\Boot Configuration, at the bottom there is an option that's called "AMI Native NVMe Driver Support" this is set to off. Would it help to turn it on?
 
NVMe SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector.

Guide to install Windows 10 on M.2 NVMe drive is in this thread:

AMI Native NVMe Driver Support can be set to [On].
 

UberOriginal

Reputable
Aug 6, 2016
16
0
4,510
0
Please do not post that again. for the 3rd time, the M.2 SSD showed up IMMEDIATELY after taking it out of the box, installing it into the M.2 slot, powered the machine back on and went into BIOS, It WAS in the boot menu. But not listed in the Advanced\SATA menu.

Besides that I powered the machine off, inserted the USB 3.0 key with windows 10 1903 on it. Turned machine on, went into BIOS, forced boot from the USB UEFI installation. Installed to the m.2 970 evo Installation went fine. I do not need a windows installation guide. I have been a basic IT tech for 11 years, really not trying to be an ass, but if this was something covered by the A+ cert I wouldn't be posting the question. "NVMe SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector. " is not true in what I experienced, I saw my m.2 drive on first boot after installing it. This is the 2nd time this reply has been copied and pasted into one of my questions. If you would have read what I wrote, I said I already had windows installed just fine, and the m.2 drive still does not appear in the Advanced\SATA menu.

I want to thank you Calvin7 though for saying "AMI Native NVMe Driver Support can be set to [On]." That is the most information Ive been able to find on that particular setting. Would you possibly be able to explain why I would turn it on and what it does exactly?
 

UberOriginal

Reputable
Aug 6, 2016
16
0
4,510
0
This is confusing me as well, in that SATA menu I've been mentioning, when i scroll to the bottom and have the m.2(gray) highlighted, it mentions "AMD APU M.2 ports"in the info section?
 

ASK THE COMMUNITY

TRENDING THREADS