Question Asus PCE-AC88 issue

Aug 8, 2021
1
0
10
0
Drops internet after a few minutes. Anything to do with network cannot be accessed.

TL : DR =
Windows 10. Asus PCE-AC88 issue. Disconnects from internet after a few minutes. Than disconnects from router. After that anything to do with network cannot be accessed. Can't left click Network icon on task bar. Clicking on Network in Settings menu cause the settings window to freeze.

So I've recently been having an issue with my Asus PCE-AC88 in Windows 10 Home. Been working perfectly since 10th of November 2020 when I got it.

Before you ask, I have tried the latest drivers provided by the manufacturer (though they came out in 2018.)

From whenever I connect to a network, after an indeterminate amount of time (sometimes 3-5 minutes, sometimes around 20 minutes) it disconnects from internet. Than disconnects from router. Before the network GUI elements crash (explained lower down the page) however, it can actually reconnect with the router, but immediately disconnects. I was observing this via my phone in the routers settings (192.168.1.1). Watching the connected devices would briefly show it connecting than immediately disconnecting.

After it disconnects from the network itself (either manually or it happens by itself after a little bit of time, also indeterminate) anything to do with network cannot be accessed.
  • Can't left click Network icon on task bar. When I do, it doesn't bring up the network panel. Nothing happens. (Hovering over it shows the hover text that it's still connected to the network I was previously connected.)
  • Clicking on Network in Settings menu cause the settings window to freeze.
  • Right-clicking network icon, than left click network and settings gives no response.
Weirdly the sound icon can't be clicked either, so somethings crashing, (Radio Management Service is still running.)

If I don't connect to a network, everything is fine. It also seems that even when the crash does happen, the rest of Windows 10 functions as it's meant to. It just crashes the network elements specifically (and partially crashes the Toolbar Icons GUI)
So far, only a hard reboot seems to fix this. If I try to restart the computer via the start menu, the 'Restarting' display stays there indefinitely.

Once I had the Control Panel > Network and Internet > Network Connections panel and the Control Panel > Network and Internet > Network and Sharing Center left open prior to the crash. After the crash happens, I checked the Network and Sharing Center, it showed network adapter connected.
The Network Connections panel showed that the Asus PCE-AC88 was indeed still connected, however, it was disabled. I could right-click for the context menu and it click to enable it. It said it was 'Enabling' > than it said 'Enabled', however it was still greyed out and 'disabled'. I'm guessing it either it didn't actually enable because of the GUI issues or it just immediately disabled itself again. No idea which.

Found a thread with a VERY similar issue to, so it's not isolated to me: https://www.reddit.com/r/Windows10/comments/fek2rs View: https://www.reddit.com/r/Windows10/comments/fek2rs/asus_pceac88_wifi_card_stops_functioning_on_w10/

I tried the newer Broadcom drivers that's suggested in the thread, but it didn't help me. Same outcome.

So my question is, anyone know what's going on and whether I have to take it back? Currently hardwired Ethernet cable isn't an option unfortunately.
 
Last edited by a moderator:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Considering you're on Windows 10, can you check and see what version you're on at the time of writing? Right click Start>System, the version should be stated at the bottom of the page. As for the platform, what is the make and model of your motherboard? Version of BIOS for said motherboard? For the sake of relevance, can you include the make and model of the router you're tethered to?

When Windows 10 first rolled out a couple of years into it with updates, often resulted in networking adapters equipped with Atheros/Qualcomm/Broadcom/Killer chips to start acting weird or loose functionality. Some work arounds were to invest in intel cards after returning said seemingly faulty/broken adapters or wait for an update from Microsoft to rectify the mistake that they'd created.

If the above asked are all the latest, try and redownload driver Version 2.8.0.7 from Asus's support site, uninstall the adapter from Device Manger, making sure to delete the driver options, then manually install the driver downloaded in an elevated command, i.e, Right click installer>Run as Administrator.
 

ASK THE COMMUNITY

TRENDING THREADS