Question Asus ROG B550-I Audio Driver Problems

g-unit1111

Titan
Moderator
I'm trying to get the audio drivers for my new B550-I motherboard installed and I haven't been successful. It's Realtek audio drivers and I am using the latest version of Windows 10 version 21H2.

Asus includes other audio related applications but when I launch those, it says that there's no audio drivers. And when I launch those, I get an error that the audio driver hasn't been properly installed. But Windows doesn't show that it uses the Realtek audio driver and instead defaults to the NVIDIA driver, which plays through my monitor and I don't want to use the monitor speakers, I want to use the external ones that I have.

Does anyone else have any experience with these drivers and can point me in the right direction?
 

dwd999

Honorable
Feb 24, 2016
87
7
10,545
1
For some reason known only to them, installing their drivers is usually a 2 step process. First you click on the AsusSetup.exe which should install some Microsoft C++ Redistributables. Then after that finishes you can click on the main Setup.exe and all of the drivers and supporting applications software should install normally. It been like this for years but eventually it always works. If you don't want the supporting applications, you can always download just the UAD drivers but you have to websearch for them. The latest version is 9202.1.
 

g-unit1111

Titan
Moderator
For some reason known only to them, installing their drivers is usually a 2 step process. First you click on the AsusSetup.exe which should install some Microsoft C++ Redistributables. Then after that finishes you can click on the main Setup.exe and all of the drivers and supporting applications software should install normally. It been like this for years but eventually it always works. If you don't want the supporting applications, you can always download just the UAD drivers but you have to websearch for them. The latest version is 9202.1.
Yeah I tried to install from the CD but it keeps crashing on me every single time. And then I tried downloading the drivers from Asus' website and they were totally useless. I will try downloading the generic Realtek drivers then.
 

bignastyid

Titan
Moderator
Something to try before the reinstall. Enter the bios and disable the hd audio save changes and exit let windows boot, then restart and go back and enable the hd audio and restart, see if that forces windows to redetect it.
 
So that didn't work. I'm starting to think something might have gone wrong with the Windows installation. Should I try maybe wiping the drive and starting over again?
You could benefit from MoKiChu's driver install for Asus audio drivers. It includes a tool to clean up the driver store for prior failed or corrupted installs.

 
Last edited:
Reactions: g-unit1111

g-unit1111

Titan
Moderator
You could benefit from MoKiChu's driver install for Asus audio drivers. It includes a tool to clean up the driver store for prior failed or corrupted installs.

Yeah this is nuts. I've never seen like this on any other current board I've used and that includes my ROG B-450.
 

ASK THE COMMUNITY