[SOLVED] Asus Rog Zephyrus g14 GA401IHR not connecting to wireless internet/driver missing.

Jan 17, 2022
2
0
10
0
So I basically bought a laptop and it arrived today. Asus Rog Zephyrus g14. When I have finished installing windows, I see the internet icon an x in red and I do not see any internet connection. I tried all the possibilities of updating the driver with a stick but nothing worked. Yes, I installed the official drivers from asus.com for this laptop model. I assume I don't have any drivers because I can't find anything in the change adapter settings. What can I do in this situation? To buy an ethernal to usb type transformer so that I can connect to the internet via cable and maybe windows will find something to fix?

I tried and run throubleshot but it tells me it didn't find any problem.

Images : View: https://imgur.com/a/lssqOZi
 
there are many Zephyrus g14 models.
include your exact product model.

and you ordered this from somewhere where an OS wasn't included?
or you just decided to do a clean install for some reason? if so, it may require some ASUS control software to properly manage their networking drivers.
does Bluetooth function properly?
 

ASK THE COMMUNITY