Asus Strix RoG GTX 1050Ti OC 4GB, PC shuts down, followed by sparks.

Feb 5, 2019
2
0
10
0
Hi all!

I wanted to upgrade my GPU and bought the Asus one, mentioned in the title. I installed it through the DP. At first I had no signal on the monitor. I tested the rest of the ports and the result was the same. After shutting down the PC, I used the DP again. This time it worked. I got an initial message that the Overclocking wasn't working properly. I installed the drivers and then tried to configure my settings. I chose 2560 X 1440 at 144Hz and then I started calibrating the colour. The computer shut down completely. I saw instantly sparks near the port of the GPU and smell came out of the tower.
I turned off the main power button. After that the PC didn't restart. I re installed the MSI card and restarted the PC. Now everything works fine!

Any ideas?

It is strange because Asus is a very good brand and my PC meets all the requirements.
The Asus has a 3 Year Limited Warranty, if it is a GPU issue, will the warranty cover it?

Thank you!

System:
i5 3470 @ 3.20Hz
MB: Asus
12GB RAM Kingston Hyper X
Win 7 64bit
Thermaltake Toughpower 850W
GPU: MSI 550Ti OC
2x SSD, 2x SATA.
 

Lutfij

Titan
Moderator
How old is your Thermaltake PSU? I also think you installed the GPU incorrectly to have sparks come out of the back of the card. Either that or your PSU is the culprit here. Might also want to take the GPU you seemingly fried to a friends/donor system with ample power from a reliable PSU and see if it works in there just to double check that the card is dead.

Is the card brand new or second hand?
 
Feb 5, 2019
3
0
10
0
Thank you for replying!

The PSU is more than 5 years old. The GPU was installed correctly, it is not the first GPU I connect. The Asus was brand new, sealed from an authorized dealer. I will return it there today. The PC is working fine now. The thing is: If get the same card (Asus) will I have a similar issue? I made a search before buying and only read good things about the card.

Can we continue this discussion here? http://www.tomshardware.co.uk/forum/id-3883513/asus-strix-rog-gtx-1050ti-4gb-shuts-sparks.html
and erase the current thread? Thank you!
 

ASK THE COMMUNITY

TRENDING THREADS