[SOLVED] ASUS TUF B450 Plus Gaming not booting for the first time, only after shutting down once

gusnd

Honorable
Mar 3, 2013
78
0
10,630
0
I just built a ASUS TUF B450 Plus Gaming with a Ryzen 2700, it does not start the boot process until I enter the setup once after shutting it down by holding the power button.

I checked every setting and got no clue what could causing this, any ideas?
 

taeioum

Upstanding
Jan 27, 2019
254
26
320
2
Does it always boot into BIOS? If not, does the system not boot normally the "second" time it's powered on? All ASUS motherboards, when first powered on (or after a power outtage or unplugging the power cable from the power supply), turn on for about 2 seconds, turn off, and then turn itself on again as normal. The second time and all times after it's booted should not show this until the power cable is unplugged again.
 

gusnd

Honorable
Mar 3, 2013
78
0
10,630
0
Probably wrong boot mode settings.
If both - legacy and UEFI boot modes are enabled, one boot mode is tried first, second one - after first one has failed. Set correct boot mode settings. Disable unused boot mode.
I found a setting related to UEFI and legacy, changed it to UEFI, going to test it later back at home


Does it always boot into BIOS? If not, does the system not boot normally the "second" time it's powered on? All ASUS motherboards, when first powered on (or after a power outtage or unplugging the power cable from the power supply), turn on for about 2 seconds, turn off, and then turn itself on again as normal. The second time and all times after it's booted should not show this until the power cable is unplugged again.
It does boot normally, it just wait for me to press F1 because it was sort of an abnormal shutdown because I had to hold the power button.

added some BIOS screenshots here View: https://imgur.com/a/Wmji09v
if it helps
 

taeioum

Upstanding
Jan 27, 2019
254
26
320
2
Try changing your Boot Option Priorities in the Boot menu. For Option #1 try selecting your OS drive. Also, disconnect any other flash drives before booting or unassign them on the other Boot Option #s.

With "booting normally" do you mean it starts up Windows and you can use your computer like anyone else would?
 

gusnd

Honorable
Mar 3, 2013
78
0
10,630
0
Try changing your Boot Option Priorities in the Boot menu. For Option #1 try selecting your OS drive. Also, disconnect any other flash drives before booting or unassign them on the other Boot Option #s.

With "booting normally" do you mean it starts up Windows and you can use your computer like anyone else would?
The SSD with windows (Windows boot manager) is already set as #1, should I set as the #1 drive anyway?

The flash drive was just there to save the screenshots.

By booting "normally" I mean no issues happening between the moment I press power and loading windows
 

ASK THE COMMUNITY