[SOLVED] ASUS Z170-AR - some unknown devices, which drivers to download?

Domarius

Distinguished
Apr 25, 2003
9
0
18,510
0
I'm on Windows 7 and bought this motherboard second hand (and I can't get in contact with the previous owner about the issue).

(I had a screenshot here but the forum flagged my post as spam) I have 2 devices with the yellow alert symbol in Device Manager: "PCI Memory Controller" and "SM Bus Controller".

Is there an easy way to tell which driver files pertain to these unknown devices?
I previously had a link to the driver download page for my motherboard, but again, forum flagged it as spam. On the ASUS driver download page, my model number is Z170-AR, and operating system is Windows 7.

I've installed all the driver files that look to me like they need installing. The thing is, the ASUS driver download page is confusing. You get the headings (like USB, BIOS) but it's not a simple case of just installing the latest file under each heading. You need to click "show all" and you'll get various versions of different files all mixed up, and it's not easy to tell what's a different version of the same file and what's a completely different file. There seems to be no order, other than perhaps the order they were uploaded in. But it's in this unsorted list that I previously found driver files that were crucial for getting the USB ports working under Windows 7.
 

Lutfij

Titan
Moderator
Host the images on Imgur and then parse the links into the post.

First make sure you're on the latest BIOS update. Then install drivers for:
Chipset; INF and MEI
Audio
USB
SATA and lastly your NIC(LAN)
and the GPU.

Might want to share your specs with us like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS: version

as well.
 

Lutfij

Titan
Moderator
Host the images on Imgur and then parse the links into the post.

First make sure you're on the latest BIOS update. Then install drivers for:
Chipset; INF and MEI
Audio
USB
SATA and lastly your NIC(LAN)
and the GPU.

Might want to share your specs with us like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS: version

as well.
 

Domarius

Distinguished
Apr 25, 2003
9
0
18,510
0
Thanks guys, I finally found the missing file to install.

Host the images on Imgur and then parse the links into the post.
Thank you, I had them on Gyazo and inserted as direct image links. To save time I just cut out all images and links when editing my post to get it accepted. Could be that a link to the image may have worked.

First make sure you're on the latest BIOS update. Then install drivers for:
Chipset; INF and MEI
Audio
USB
SATA and lastly your NIC(LAN)
Thank you, with this info, and process of elimination, I managed to get the right file installed. I tell you, the ASUS Download site is terrible. (See below FYI)

actually have this board, the site is pretty clear:
you need the Chipset download (includes ME) so both items should resolve fine

https://www.asus.com/us/Motherboards/Z170-AR/HelpDesk_Download/
No, it is totally not clear XD and no, that first file does not fix the issue, I already had it installed. Sure, the heading "CHIPSET" is obvious, but it only shows one file. Expanding "Show all" gives you a huge list of files. First 2 are both the Management Engine, one is an older version of the same file. 3rd file down is the "Intel Chipset" and this file fixed the issue.

Those categories present themselves as one file, with older versions - when actually it's a mystery box that you have to scroll through older versions of the same file before you may get to a different file. I had to do the same thing to find the missing USB drivers.

And I only learned I should expand "show all" indirectly by an unrelated video on their site on installing the BIOS updater (seems that realised you need a an instructional video to learn how to use their site - that's not a good thing).
 

ASK THE COMMUNITY

TRENDING THREADS