Question Audio has stopped working, as has Windows update

TprSmid

Honorable
Jul 25, 2014
18
0
10,510
0
Hi all,

I'm really stumped here - any advice would be welcome.

My PC's audio has suddenly stopped working for no apparent reason. I've spent ages searching for solutions and have tried the following, none of which has worked:

1) Check audio wasn't muted (it wasn't, obviously) and checked levels etc.

2) Drivers - checked latest Realtek drivers were installed (they were). Tried rolling back drivers - that didn't work. Tried uninstalling Realtek ones and installing generic HD audio driver instead. That didn't work. Back to latest Realtek drivers now (6.0.8703.1)

3) Output device - changed from speakers (wired to the back of the PC through a 3.5mm jack) to wireless headphones. That didn't work.

4) Ran Windows Sound Troubleshooter, which says "Audio Services not responding". I've used 'services.msc' to check and Windows Audio is running (and I've restarted it too successfully), as is Windows Audio Endpoint. There's a Multimedia-related process that is missing though (I can't remember the name of it but I think it should be there). I'm thinking this could be the issue? How do I fix that?

Other points to note - if I try to play a test tone for any of the output devices (Speakers or Headphone) I get a 'Failed to play the test tone' error message.

I have also tried running Windows Update but get the following error message after it finds an update available and then says Status: Getting things ready - 0% :

"Feature update to Windows 10, version 2004 -Error 0x80072f8f"
Status: We couldn't connect to the update services. We'll try again later..."

FYI I'm running Windows 10 64-bit.

Like I said, I'm completely stumped and am increasingly annoyed at not being able to fix the lack of audio (or update my copy of Windows). Any ideas welcome!

Cheers.
 

TprSmid

Honorable
Jul 25, 2014
18
0
10,510
0
Reinstalled Windows. Audio is working if I plug the speakers into the front headphones jack of my case, but not the rear ports on the Motherboard. Weird.

I've run Windows Update and it says Updates available, but they're all 'Pending Download'. Any idea how to start them??

I'm also trying to download the NVidia Control Panel via the Microsoft Store and that's not working either!
 

ASK THE COMMUNITY