• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

[SOLVED] B450M Steel Legend - Unable to Access BIOS

Feb 2, 2021
4
0
10
0
Hey guys, first post here!

I have a B450M Steel Legend MOBO, and I'm not being able to access its BIOS. Mine is with version 3.30, and I can't access the BIOS in any way, either by clicking F2 at startup, or using Windows Advanced Boot Settings, or using AsRock's Restart to UEFI.

When restarting, it's stuck in the black screen. Then, I need to reset to come back to Windows.

It's with the XMP enabled (I have 16GB 3200MHz - 2x8GB installed) and I just replaced the DC fans (without control) with fans with PWM control, and I would like to configure them.

In addition, I bought another equal pair of 16GB (2x8GB) to increase my RAM to 32GB (I work with audio) and I would like to check the BIOS if something happens after including those RAMs (which should arrive next week).

Do you have any idea what to do?
Thanks
 

Ds_Tech

Great
Jan 25, 2021
185
14
95
17
Ok if it not showing may be in bios setting you have chosen legacy bios not uefi-may be check that.
after reset bios you have to load default settings in bios and save and exit.
And due to ssd system boot fast so you have to press del key as soon you start pc to enter in bios.
 
Reactions: TheOgre
Feb 2, 2021
4
0
10
0
Did you try reset the bios?
Not yet.

I know it doesn't have much to do, but the MOBO is new, I have the PC for about two months only. I had accessed the BIOS before, but had not tried to enter for a few weeks.

But anyway. Yesterday I tried, once again, to enter during the boot using the DEL, and this time it worked. I've already changed the fans control to PWM (they were all set to AUTO). Then, I entered Windows, restarted and tried again (DEL), and it worked again. Well, I don't know what was going on, but it seems that momentarily, it is solved. If it happens again, I'll take the battery out to clean CMOS.

Try cmos clear.
Remove cmos battery and install it in system off mode.
and disable fastboot in windows also.
Where do I disable the fastboot? I saw some videos, where is shown that the fastboot is disabled in the power options - shutdown settings section, but I can't find it there, only sleep and hibernate.
 

Ds_Tech

Great
Jan 25, 2021
185
14
95
17
Ok if it not showing may be in bios setting you have chosen legacy bios not uefi-may be check that.
after reset bios you have to load default settings in bios and save and exit.
And due to ssd system boot fast so you have to press del key as soon you start pc to enter in bios.
 
Reactions: TheOgre

ASK THE COMMUNITY