Bios not recognized my hdd but Windows does

marnow955

Commendable
Sep 13, 2016
3
0
1,510
0
After cloning my old system from hdd to ssd using hdd caddy second drive disappear from bios and windows. I swapped them and clean install windows on ssd, then when i put hdd into caddy and change sata controller to standard (not intel 8 chipset) windows start to see second drive, but bios still not see it at all.
Also Ubuntu install not recognized hdd. Is there a chance to set up sata controller in ubuntu livecd session or bios set up to recognized him?
sorry for my English...I hope it is understandable
 

marnow955

Commendable
Sep 13, 2016
3
0
1,510
0


Lenovo G510 and hdd caddy is connected to SATA port
 
Welcome to the community, @marnow955!

Have you tried resetting BIOS through the settings in the interface? I'd recommend you to do so and check if the HDD would be properly detected then. Another thing I'd advise you to do is see how the HDD would get recognized if you configure the SATA mode to AHCI. You might as well check if you have the latest SATA controller & chipset drivers installed for your laptop from the manufacturer's official website.

Hope it helps. Keep us posted.
SuperSoph_WD
 

marnow955

Commendable
Sep 13, 2016
3
0
1,510
0


Thanks for reply.
Yes, resetting BIOS through the interface didn't work. SATA mode is in AHCI, I tried switch it to IDE but this also not work for me. I install on the SSD clear Windows and drivers that come with laptop (there's nothing new on the manufactured website). With this SATA controller HDD those not appear in Windows, only if I use standard SATA controller I can see HDD partitions in Explorer, and this is ok, but i want to boot from the HDD second system and BIOS still not recognized my old hard drive.

I see that Lenovo release BIOS update, do you think it would help?
Is it possible that the old Windows did some isues? When I first connect SSD to my laptop everything was all right, and after colonig theres some "irql not less or equal" error and after that even when I install not cloning Windows on the SSD theres nothing in my BIOS and to see the drive in Windows I must switch to standard SATA controller...


Nope, BIOS update not help
 

ASK THE COMMUNITY

TRENDING THREADS