Question Black screen after driver installation - not a driver problem

AfikH

Reputable
Sep 26, 2016
41
0
4,530
0
Hello,

My computer was acting weird lately so i decied to format it.
After reinstalling windows 10 i booted up into windows and everything was fine
until a few minutes later when a black screen has appeared.
Once the black screen has appeared every boot of my pc to windows gave me this black screen.
I figured out the black screen was appearing because of windows 10 automatically installing graphics drivers,
so i tried to manually install drivers from AMD website with no success - same result. Tried older drivers as well - same result.
So i thought mabey it's something with this version on windows that has compatibility issues with this gpu or gpu drivers or what else.
Then i've tried to install Windows 7 and everything was fine. With windows 7 the black screen did not appeared until i have installed gpu driver manually,
I guess that's because Windows 7 didn't installed graphics driver automatically because i've disabled this feature.

Anyway i dont know what to do. It's definitely not os problem and not driver issues.
So i came here to ask what could it possibly be.

My pc specs :
i3 3220
sapphire amd r9 270x
8gb ram
600w psu
500gb ssd

Thanks in advanced, Afik !
 

AfikH

Reputable
Sep 26, 2016
41
0
4,530
0
make and model of the 600w psu?
test with igpu only?
Hay thanks for reply,
I've mistaken the psu watt it's a 550w psu from zumax
It's called zumax pro zp550gw . i know it's a low grade psu but it worked before .

I've replaced the r9 270x with an old pcie gpu that i've found in my drawer - Nvidia gf 9500 gt .
successfully booted up into windows after gpu replacement .
But would still love to know if there is a possiblity that my r9 270x wasn't the problem and is still alive .

Thank again !
 

AfikH

Reputable
Sep 26, 2016
41
0
4,530
0
You will have to test the other card in another system maybe take it over to a friend who has a spare system to test with
problem about anything is sometime they failed
Hay,
I will try to test the GPU on another system.
Let's say that it is working on another system.
Does it make the PSU the problem necessarily or the problem still could be something else like the mobo or something .

Thanks !
 

ASK THE COMMUNITY

TRENDING THREADS