Question Brand New i9-9900k RTX 2080 Gaming PC stopped powering on

Jun 10, 2019
4
0
10
0
My gaming PC is not turning on even though everything is plugged in and was working earlier in the day. My computer has power running through it (Asus Strix) MOBO is lit up but actual PC just doesn't turn on. The corsair keyboard and Logitech mouse I got are new and the lights on them are on as well. Any ideas as to why this happened?
 
Jun 10, 2019
4
0
10
0
full system spec? include make and model of the psu
Here are the specs:

Intel Core i9 9900K OC to 5.1Ghz
Asus Strix Z390 E Gaming motherboard
NZXT X62 280mm radiator
ASUS ROG STRIX GeForce RTX 2080 Overclocked 8G
Gskill Tridentz 4x8GB DDR4 3000Mhz
Seasonic PRIME Ultra 1000W 80+ Platinum with custom sleeved cable
Samsung 970 NVME 1TB (OS Installed)
Crucial 1tb SSD
Seagate 2TB HD
NZXT H700i
Windows 10 Pro 64 Bit
TT Riing Plus 3x140mm
TT Riing Plus 2x120mm
NZXT led strip
 

jankerson

Illustrious
BANNED
Here are the specs:

Intel Core i9 9900K OC to 5.1Ghz
Asus Strix Z390 E Gaming motherboard
NZXT X62 280mm radiator
ASUS ROG STRIX GeForce RTX 2080 Overclocked 8G
Gskill Tridentz 4x8GB DDR4 3000Mhz
Seasonic PRIME Ultra 1000W 80+ Platinum with custom sleeved cable
Samsung 970 NVME 1TB (OS Installed)
Crucial 1tb SSD
Seagate 2TB HD
NZXT H700i
Windows 10 Pro 64 Bit
TT Riing Plus 3x140mm
TT Riing Plus 2x120mm
NZXT led strip

Well that MB isn't all that great for the 9900K at all, especially OCed, the VRMs are not good, only has an 8 Phase VRM and it's not a great one.

ASUS blew it for the most part with the Z390 MB's except for their HIGH END MODELS.

You can try resetting resetting the bios and see if it boots.
 
Jun 10, 2019
4
0
10
0
Here are the specs:

Intel Core i9 9900K OC to 5.1Ghz
Asus Strix Z390 E Gaming motherboard
NZXT X62 280mm radiator
ASUS ROG STRIX GeForce RTX 2080 Overclocked 8G
Gskill Tridentz 4x8GB DDR4 3000Mhz
Seasonic PRIME Ultra 1000W 80+ Platinum with custom sleeved cable
Samsung 970 NVME 1TB (OS Installed)
Crucial 1tb SSD
Seagate 2TB HD
NZXT H700i
Windows 10 Pro 64 Bit
TT Riing Plus 3x140mm
TT Riing Plus 2x120mm
NZXT led strip
full system spec? include make and model of the psu
Well that MB isn't all that great for the 9900K at all, especially OCed, the VRMs are not good, only has an 8 Phase VRM and it's not a great one.

ASUS blew it for the most part with the Z390 MB's except for their HIGH END MODELS.

You can try resetting resetting the bios and see if it boots.

Which PSU do you suggest I switch to by chance? And how do I reset it if it doesn’t even boot up? Thanks in advance
 
Jun 10, 2019
4
0
10
0
The PSU is fine.

Pull the GPU out and reset the BIOS and see if you can get into the bios.

If in doubt switch the PSU cables to the Seasonic ones.

I will try that today after work. Here’s a little more insight on my problem. I was gaming a little earlier in the game but then my PC blue screened/crashed 2 or 3 times in the span of an hour. My CPU was overheating so it shut down to prevent it from flaming out. So after the last blue screen I shut it down completely. A hour later I tried turning on the PC and nothing happened. Not any noise and no effort to even turn on. Do you still think I should reset the GPU or go another route? Thanks in advance for all your help!
 

jankerson

Illustrious
BANNED
I will try that today after work. Here’s a little more insight on my problem. I was gaming a little earlier in the game but then my PC blue screened/crashed 2 or 3 times in the span of an hour. My CPU was overheating so it shut down to prevent it from flaming out. So after the last blue screen I shut it down completely. A hour later I tried turning on the PC and nothing happened. Not any noise and no effort to even turn on. Do you still think I should reset the GPU or go another route? Thanks in advance for all your help!

Yeah, and reseat the CPU cooler, remove thermal paste and put on new also.
 

ASK THE COMMUNITY

TRENDING THREADS