Question Built a new pc but I am not getting a display!

May 2, 2020
6
0
10
0
I just built a new pc and the specs are
Gtx 1660 6gb
Gigabyte B450M motherboard
Corsair vengeance 16gb ddr4
Ryzen 5 2600
600 EVGA power supply
I recently just got done building this pc and I can’t get a display with my graphics card. If I put my gtx 1060 from my other computer it will work just fine and if I put my 1660 in my other computer it will also work just fine. Really just want to know what I can do to fix this issue. I tried switching out power supply’s to no avail, is this a motherboard or graphics card issue?
 

Djoza

Notable
Apr 5, 2020
1,182
165
940
34
maybe a bios update,but you said that if you put your 1060 in you get a signal.So that leads us to three things.Bad GPU,bad RAM,or bad something else i cant think of now.Try booting with just 1 ram stick on every DIMM slot possible and see if it works (maybe 1 dimm slot failed),also one really stupid thing that caused my friend a simillar issue is windows.Try reinstalling windows completely,fresh start.That worked for him and he did same thing,just switched the gpu.Tell me what happens.

Edit:Also try reinstalling the 1060 drivers ussing DDU,and boot with your 1660 and see what happens
 
May 2, 2020
6
0
10
0
maybe a bios update,but you said that if you put your 1060 in you get a signal.So that leads us to three things.Bad GPU,bad RAM,or bad something else i cant think of now.Try booting with just 1 ram stick on every DIMM slot possible and see if it works (maybe 1 dimm slot failed),also one really stupid thing that caused my friend a simillar issue is windows.Try reinstalling windows completely,fresh start.That worked for him and he did same thing,just switched the gpu.Tell me what happens.

Edit:Also try reinstalling the 1060 drivers ussing DDU,and boot with your 1660 and see what happens
Okay. I tried a single stick in every ram slot still nothing. And by reinstalling windows I should put my 1060 back in so I can do that. I just installed windows like 2 hours ago btw
 

Djoza

Notable
Apr 5, 2020
1,182
165
940
34
Okay. I tried a single stick in every ram slot still nothing. And by reinstalling windows I should put my 1060 back in so I can do that. I just installed windows like 2 hours ago btw
if u just installed windows 10 i dont think you need to do it again,just delete the 1060 drivers using ddu and after that boot with the 1660 and tell me what happens
 
May 2, 2020
6
0
10
0
if u just installed windows 10 i dont think you need to do it again,just delete the 1060 drivers using ddu and after that boot with the 1660 and tell me what happens
Just got done doing that. I Chose clean and shutdown and I installed the gtx1660 still no display. Also to mention my keyboard and my mouse show no signs of power either. Been like this even before cleaning using ddu
 

Djoza

Notable
Apr 5, 2020
1,182
165
940
34
trust me.I have had the SAME EXACT problem with my r9 380.Put it in,no signal,keyboard and mouse not working,and the only thing that solved this problem was another PSU.i am 99% possitive that this is a psu problem.If u can take the psu from your other computer and put it in the 1660 build and see if it works.If that doesnt work,maybe a faulty gpu.But imma be honest here,1060 will work damn fine in todays games with the rest of your setup.I cant see that big of difference between 1060 and a 1660.If this fails just hold on to the 1060 until you find a solution.Keep researching and maybe go to local pc fixing place (i dont know how that place is called but in my country we call it pc servise)

Best of luck my brother :)
 

Djoza

Notable
Apr 5, 2020
1,182
165
940
34
also i dont know why you bought a 1660 over a 1060.Most people whould go for the rtx series but its your choice.My advice is if this doesnt work,sell the 1660,collect some money,mow some lawns and buy that rtx gpu that we all wish for.
 
May 2, 2020
6
0
10
0
trust me.I have had the SAME EXACT problem with my r9 380.Put it in,no signal,keyboard and mouse not working,and the only thing that solved this problem was another PSU.i am 99% possitive that this is a psu problem.If u can take the psu from your other computer and put it in the 1660 build and see if it works.If that doesnt work,maybe a faulty gpu.But imma be honest here,1060 will work damn fine in todays games with the rest of your setup.I cant see that big of difference between 1060 and a 1660.If this fails just hold on to the 1060 until you find a solution.Keep researching and maybe go to local pc fixing place (i dont know how that place is called but in my country we call it pc servise)

Best of luck my brother :)
Okay. I will try that out in a bit. I’ll keep this updated. Hopefully it’s just a psu. Thanks for all the help
 
May 2, 2020
6
0
10
0
Welp. Put the known g
im 99% sure and hope its the psu,but who knows

Good luck
welp. Put the known good power supply In still nothing. Bad graphics card or motherboard? Thoughts? I do notice when I put a graphics card in this mother board it doesn’t hold the graphics card as snug as my known good one (without the screws holding it in place) could it be just a bad pcie slot?
 

Djoza

Notable
Apr 5, 2020
1,182
165
940
34
??? not holding it in place??

That leads to 1 solution.GPU SAG.
It ussually is when a gpu is not conected right and is still not stable even when you screw it in.You know that felling when you touch your gpu and its moving a lot,well thats it.Look at these 2 videos and see if you can relate to at least one of it.

Jayztwocents:
View: https://www.youtube.com/watch?v=EOXYE3hx_JY


Pauls hardware:
View: https://www.youtube.com/watch?v=JNLRZwC-CsQ


Both are really good and popular tech youtubers,and you can trust them.Honestly when you reported that you had no signal i was sure it was the psu,because u dont get a lot of complains about gpu sag.Either way good luck,and i forgot to tell you this but what happens when 1660 is in you pc,but you connect your video cable to the motherboard??
 
May 2, 2020
6
0
10
0
??? not holding it in place??

That leads to 1 solution.GPU SAG.
It ussually is when a gpu is not conected right and is still not stable even when you screw it in.You know that felling when you touch your gpu and its moving a lot,well thats it.Look at these 2 videos and see if you can relate to at least one of it.

Jayztwocents:
View: https://www.youtube.com/watch?v=EOXYE3hx_JY


Pauls hardware:
View: https://www.youtube.com/watch?v=JNLRZwC-CsQ


Both are really good and popular tech youtubers,and you can trust them.Honestly when you reported that you had no signal i was sure it was the psu,because u dont get a lot of complains about gpu sag.Either way good luck,and i forgot to tell you this but what happens when 1660 is in you pc,but you connect your video cable to the motherboard??
I will check those videos out. And nothing happens. When ever I have the 1660 in the computer it won’t turn on, as in no display and no output to mouse and keyboard
 

ASK THE COMMUNITY