Question Built-in and external keyboard not working on Fujitsu Lifebook AH42/H ?

Apr 19, 2021
2
0
10
0
Hello guys,

Would like to know if anyone had a problem like mine and have any suggestion ...
My mother-in-law gave me her notebook saying that the keyboard was not working and if I could format to solve this...


Long story short here is the point...

[Laptop]
  • Fujitsu Lifebook AH42/H (Was bought in Japan, guess in 2014)
  • Windows 7 (original) -- haven't got the build to post here sorry...
[Symptoms]
  • Internal keyboard is not working properly
  • External keyboard (USB) doesn't work either
  • On-screen keyboard act the same as both before
  • If I hit "W" key it acts like CTRL+W, closing a windows
  • If I hit "T" key it keeps opening tabs while in a browser
  • The "Enter" key works fine
  • Numbers key or "F something" keys don't work
  • Function key + some other key seems not working
  • The trackpad is working fine
  • Capslock, numlock turns the respective light on
[Troubleshooting]
  • Connected external keyboard with no success
  • Tried on-screen keyboard with no success
  • Antivirus checkup got nothing
  • Checked device manager for any driver problems and everything was fine
  • Updated and reinstalled keyboard drivers no success
  • Searched on Google no solutions from similar problems worked
  • Restored Windows the same problem happened
  • Using a USB driver upgraded windows from 7 to 10, still with the issue
  • Opened the laptop and removed the keyboard, was dirty but it doesn’t look like any liquid fell, without rust marks...
With all that I have to say that I can't get into the BIOS as I can't hit F2 nor F12 key on the boot screen
Tomorrow will try the CMOS reset
Really seems some motherboard connector malfunction
As this laptop is from 2012 maybe the time has come and it should just pass away and rest in peace? hahaha
I'm not experienced with hardware at all so any suggestions are welcome!

thanks
Cheers
 
Last edited:
Apr 19, 2021
2
0
10
0
Guys,

Just an update about my issue.

[The Problem]
- CTRL is logically been pressed all the time

[Troubleshooting]
  • Searching more in forums, found some Sticky keys issue, unfortunately going setting --> Ease Access --> Keyboard, and turning off 'Use Sticky keys', 'Use Toggle Keys' and 'Use filter keys" did not solve the issue.
  • Found that pressing CTRL + ALT + DEL and exiting with "ESC" solves my problem for a few moments then the problem persists.
  • Tried to hold CTRL + Shift for 15s (as some other guys mentioned) with no effect.
  • Tried to press both CTRL, no effect.
  • Uninstalled keyboard driver, rebooted, no effect.
  • Removed physically the CTRL key and seems it was not stuck.
  • Updated windows 10 to its last version, not solved.
[Workaround]
- Downloaded SharpKey program and disabled both CTRL keys in the registry.

Disabling the CTRL key made me able to use the keyboard again. It's just a workaround but solved the issue.
Guess will no further investigate this as my mother-in-law doesn't even use CTRL + C/CTRL +V so no need to spend more time on this...
Hope that if someone else is facing this weird issue, this workaround might help even though it's not the best solution...

Thanks, folks
C'ya
 

ASK THE COMMUNITY

TRENDING THREADS