Question Call of Duty Modern Warfare closes with no error

Oct 18, 2020
12
1
15
0
CPU: Intel Core i5-8400 CPU @ 2.80GHz, 2801 Mhz, 6 Core(s), 6 Logical Processor(s)
GPU: NVIDIA GeForce GTX 970
RAM: 16gb
SSD: CRUCIAL MX300 SSD
PSU: 650 Watt

I have never had this issue until recently. This issue persists between Modern Warfare and the Black Ops Cold War beta. I open the game, and anywhere from instantly to 5 minutes after launch, the game will close with no error.

Things I have tried:
-Updating GPU drivers
-Updating CPU drivers
-Dusting out my PC
-Checking CPU temps (says 64° in game)
-Setting the game to run as admin
-Lowering in game settings


I will only try resetting my PC as a last resort, as I reset my PC around a month ago. I highly doubt that I have a malware issue, but I am currently doing a full scan with Windows Defender. Thanks for the help. I will also say that when running either game, my CPU usage seems to be abnormally high. I assume that the issue is with my CPU, but I can't pin point the issue. Thanks for the help.
 
Last edited:
Oct 18, 2020
12
1
15
0
How old is your PSU, and is your hardware in the recommend specs for cod cold war?
I meet the recommended specs for Modern Warfare, and I meet the minimum specs for Black Ops Cold War. I would say that I installed my PSU around 2015 or so. My PSU is fine. If anything I would say that it's an issue with my CPU.
 
Oct 18, 2020
12
1
15
0
Could be something with the beta, maybe repost on this forum to gain more attention, or ask Activision or something.
It's not just an issue with Black Ops Cold War. The same thing is also happening to Modern Warfare. I can't play either game right now. Also I have asked on Blizzard, Reddit, and Activision Support, and you are the only person to have answered so far. Thanks for the help.
 
Oct 18, 2020
12
1
15
0
run task manager when you are opening them up maybe it can reveal something is happening when booting the game up.
I already did that once and it seems to use 80% CPU on startup, making the whole CPU usage spike to 100%, but then once it gets to the menu it seems to calm down and go back down to 50%. I would be worried about this, but it has always done this to me.
 
Oct 18, 2020
12
1
15
0
yeah, that isnt out of the ordinary.
I would blame the recent MW update, but it's happening with both Modern Warfare and Cold War. I would also blame my CPU, but it seems to work just as always. I would say it's my GPU or the drivers, but I did a clean install of the recommended drivers using DDU.
 

HeyItsFroggy

Honorable
Dec 1, 2014
20
0
10,520
1
CPU: Intel Core i5-8400 CPU @ 2.80GHz, 2801 Mhz, 6 Core(s), 6 Logical Processor(s)
GPU: NVIDIA GeForce GTX 970
RAM: 16gb
SSD: CRUCIAL MX300 SSD
PSU: 650 Watt

I have never had this issue until recently. This issue persists between Modern Warfare and the Black Ops Cold War beta. I open the game, and anywhere from instantly to 5 minutes after launch, the game will close with no error.

Things I have tried:
-Updating GPU drivers
-Updating CPU drivers
-Dusting out my PC
-Checking CPU temps (says 64° in game)
-Setting the game to run as admin
-Lowering in game settings


I will only try resetting my PC as a last resort, as I reset my PC around a month ago. I highly doubt that I have a malware issue, but I am currently doing a full scan with Windows Defender. Thanks for the help. I will also say that when running either game, my CPU usage seems to be abnormally high. I assume that the issue is with my CPU, but I can't pin point the issue. Thanks for the help.
Hello, around awhile back I had a similar issue like yourself, I would load up get into a game and then get disconnected from their servers.

I found a fix to resolve my issues, and to be honest, I was forced basically to reinstall windows 10 and it fixed all of my game problems. If you would like to save time reinstalling everything then move your important game files to a different drive and reinstall your OS to a separate drive (e.g. an SSD).

I hope this solves your issues that you're having currently right now. Good luck and happy gaming!
 
Oct 18, 2020
12
1
15
0
Hello, around awhile back I had a similar issue like yourself, I would load up get into a game and then get disconnected from their servers.

I found a fix to resolve my issues, and to be honest, I was forced basically to reinstall windows 10 and it fixed all of my game problems. If you would like to save time reinstalling everything then move your important game files to a different drive and reinstall your OS to a separate drive (e.g. an SSD).

I hope this solves your issues that you're having currently right now. Good luck and happy gaming!
"Hey, just nuke your pc and start over from the very beginning." Thanks for the tip.
 
Reactions: Maxvj

HeyItsFroggy

Honorable
Dec 1, 2014
20
0
10,520
1
"Hey, just nuke your pc and start over from the very beginning." Thanks for the tip.
Not entirely true, you're experiencing an issue and you're asking for help. I'm trying to help you.

Bottom line short, if everything you have done doesn't do <Mod Edit> then reinstall windows and see what happens from there.

Also, the new call of duty games are very demanding in computer specs. (MW and Cold War)

The most you could possibly lose would be time that you could have playing the open beta that ends tomorrow at 10am PT.
 
Last edited by a moderator:
Oct 18, 2020
12
1
15
0
Not entirely true, you're experiencing an issue and you're asking for help. I'm trying to help you.

Bottom line short, if everything you have done doesn't do <Mod Edit> then reinstall windows and see what happens from there.

Also, the new call of duty games are very demanding in computer specs. (MW and Cold War)

The most you could possibly lose would be time that you could have playing the open beta that ends tomorrow at 10am PT.
From the little I was able to play before crashing, I could care less about the beta. I only care for the zombies. The multiplayer seems horrible.
 

ASK THE COMMUNITY

TRENDING THREADS