Question Cannot get motherboard screen to display when plugged into GPU

Sep 8, 2019
2
0
10
0
Hello everyone. First question on Tom's Hardware, thank you in advance for any assistance here.

So I have recently added another SSD to my desktop and installed Fedora on it (the machine has primarily been running Windows up until this point). This is on a completely secondary SSD, it is not that I partitioned the original that contains Windows (I don't believe this matters in regards to my issue but figure I'd describe my setup well). Because of this, I now frequently have a desire to utilize the boot menu of my motherboard to pick which drive to boot from.

My issue is that I seem to be unable to get my motherboard to use the GPU to display the initial startup screen which contains the "Press F12 to enter Boot Menu". If I press F12 anyway, it will enter the boot menu however since there is no display I can only guess what I am selecting. The only sane way I seem to be able to choose which drive to boot from, is to crawl down on the floor, switch the display port from the GPU to the motherboard, and then boot the computer.

If I'm willing to accept the default drive to boot from (which I've changed back and forth between windows and Linux a few times already trying to decide "ok which one do I use more"), once the OS starts booting up the GPU does and always has worked fine. It hasn't been until now that I frequently want to decide which drive to boot from that I've even noticed this problem of mine.

My initial suspicions here are that this is driver related, since it is the operating system that runs the drivers for GPUs. But this blows my mind that there would be no way to render even minimal display resolution and colors through the GPU, with the motherboard prior to OS load. There has to be something I'm missing here to get this to work.

Motherboard / GPU Models:
  • Gigabyte GA-Z170X-Gaming G1
  • Two NVIDIA GeForce GTX 1080 Ti FTW3 (no SLI bridge)
Out of desperation I tried both GPUs to have my display port plugged into, still no luck getting to view the motherboard menu through them.

Any help here would be greatly appreciated. Starting to get sick of crawling down on the floor with each time I want to switch operating systems.

Thanks again.
 

ASK THE COMMUNITY

TRENDING THREADS