• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Cannot get past Dell loading screen after disabling display driver

Jun 20, 2020
8
0
10
0
I disabled my integrated graphics display driver in Windows display driver and now my computer doesn't boot past the Dell loading screen. I've tried replacing my cmos battery to no avail
Plz help!
Thanks
 
Jun 20, 2020
8
0
10
0
Model's a Dell XPS 8900

I've tried mashing the F8 key on start-up to enter safe mode but it doesn't work. I've also tried starting up computer with the graphics card connected via HDMI to my computer but still doesn't work. Any other suggestions?

Thanks!
 
Jun 20, 2020
8
0
10
0
was there a reason to disable it?

when you said "doesn't boot past the Dell loading screen", did it black screen?

There are different config on the 8900, what gpu did it have?
the monitor displayed the dell logo and the spinning circle but then just stopped. for the dedicated gpu I cant remember the exact model but it was some low level Nvidia card that came with the cpu.
 
Jun 20, 2020
8
0
10
0
if you have another working pc. get a usb flash drive. download windows 10 iso from microsoft website and do a system repair from it
would it still work if I plugged a recovery drive into my PC as it literally just shows a black screen and I cant see whats going on or if its even working
 
Jun 20, 2020
8
0
10
0
it now showing just the black screen?

back to the gpu. does it have dvi on that?
the screens still stuck on the dell logo but it doesn't respond if I stick a USB in it so I cant tell if it works

for the Nvidia card it has both hdmi and dvi ports but i only have an hdmi cable
 
Jun 20, 2020
8
0
10
0
change the boot seq to start with the recovery disk
unfortunately I'm clueless on how to change it. when I click on the boot sequence subheading there's a text box on the right with 'boot list option' and 'legacy' and 'uefi' options. i cant change it to legacy boot mode. do I click 'add boot option'? if so what do I write for 'boot option name' and 'file name'?

Thanks in advance
 

ASK THE COMMUNITY

TRENDING THREADS