Cannot isntall/remove any network devices

G

Guest

Guest
Archived from groups: microsoft.public.win2000.advanced_server (More info?)

Hello.

I am hoping you can help me, as I have been scouring the
internet, and there seems to be noone with this problem
except me.

I have a Windows 2000 advanced server based network, with
only 1 active directory server. This server acts as the
gateway out to the internet as well, which is through a
Direcway system. (LinCsat actually, as we are in Canada,
but it is all the same hardware and software)

Anyhow, several months ago, I installed the Earthlink
version of the software which has a DNE or deterministic
network enhancer built into it somehow.

After installing that version of the direcway software,
we started having very strange problems with the
networking portion of the operating system. ie. I can't
make changes to the network connections. Thankfully it
was all still "working" unless you tried to tamper with
settings etc... So it has been that way for months.

NOW, yesterday I decided to try and finally fix the
problem. I removed the software and in device manager
there were 15+ items under network connections that
said "deterministic network enhancer miniport" I could
not remove them at all, nor could i remove the network
adaptor.

I found on your website some instructions on how to
uninstall the DNE drivers but the thing is nowhere on the
hard drive of the server is there a dneinst.exe or dne*.*
anything for that matter, and i can not find a copy of
the dne drivers anywhere on the internet...

So, I tried to remedy things by editing the registry.
(hindsite tells me that was a bad idea) I deleted any
key that had reference to deterministic networks and
rebooted. At first glance everything seemed fixed as I
had no more deterministic miniports in device manager,
however now I have a new and seemingly much bigger
problem. I cannot install any network devices at all.
If i try to uninstall the existing network card driver
(Dlink 530TX NIC) I get a message saying "cannot
uninstall driver" and "this driver is required for the
system to boot" which i know is BS, as its just a NIC.

I know the problem is stemming from the fact that somehow
the system is still looking for the dne (deterministic
network enhancer) protocol that the Direcway software
must have installed, but I cant figure out how to remove
it.

I have tried to reisntall TCP/IP using the microsoft KB
article that explains how on a domain controller, but
that didnt work. I cant uninstall DNS or DHCP because
when I do the setup program says a file is missing and it
won't continue.

I cannot just rebuild the server as they have 150+ user
accounts and on top of all of this they are running MS
Exchange server too (with all its wonderful complications)

Is there a way to remove the deterministic network
enhancer protocol or furthermore a way to reinstall the
networking components somehow to remove reference to this
DNE protocol that really does not exist.

The other strange thing about this is that the DNE is not
installed on any other Direcway system I have checked, so
I am guessing it must be the earlier earthlink version of
the software. (also I had a 3COM nic in there 905TX but
I dont think it was that)

It is Friday 9PM here and I have to have this up and
running by Tuesday AM at the very latest. I have been
pulling my hair out for 15+ hours on this now...

Any suggestions would be EXCELLENT!!!


Thank you!


John Shoff
jshoff@realitybytes.ca
 
G

Guest

Guest
Archived from groups: microsoft.public.win2000.advanced_server (More info?)

I would call MS support and do what is known as a networking rip. This will
remove the registry keys for networking so they can be reisntalled. This is
not fun especially on a domain controller with Exchange and I would make a
full backup of everything before doing anything else. Your best bet would be
to take another box and install it as a Domain Controller at least until
this box is back running that is of course if networking is working at all?

--
Scott Harding
MCSE, MCSA, A+, Network+
Microsoft MVP - Windows NT Server

"John Shoff" <jshoff@realitybytes.ca> wrote in message
news:17e5901c41ea6$c89cf330$a601280a@phx.gbl...
> Hello.
>
> I am hoping you can help me, as I have been scouring the
> internet, and there seems to be noone with this problem
> except me.
>
> I have a Windows 2000 advanced server based network, with
> only 1 active directory server. This server acts as the
> gateway out to the internet as well, which is through a
> Direcway system. (LinCsat actually, as we are in Canada,
> but it is all the same hardware and software)
>
> Anyhow, several months ago, I installed the Earthlink
> version of the software which has a DNE or deterministic
> network enhancer built into it somehow.
>
> After installing that version of the direcway software,
> we started having very strange problems with the
> networking portion of the operating system. ie. I can't
> make changes to the network connections. Thankfully it
> was all still "working" unless you tried to tamper with
> settings etc... So it has been that way for months.
>
> NOW, yesterday I decided to try and finally fix the
> problem. I removed the software and in device manager
> there were 15+ items under network connections that
> said "deterministic network enhancer miniport" I could
> not remove them at all, nor could i remove the network
> adaptor.
>
> I found on your website some instructions on how to
> uninstall the DNE drivers but the thing is nowhere on the
> hard drive of the server is there a dneinst.exe or dne*.*
> anything for that matter, and i can not find a copy of
> the dne drivers anywhere on the internet...
>
> So, I tried to remedy things by editing the registry.
> (hindsite tells me that was a bad idea) I deleted any
> key that had reference to deterministic networks and
> rebooted. At first glance everything seemed fixed as I
> had no more deterministic miniports in device manager,
> however now I have a new and seemingly much bigger
> problem. I cannot install any network devices at all.
> If i try to uninstall the existing network card driver
> (Dlink 530TX NIC) I get a message saying "cannot
> uninstall driver" and "this driver is required for the
> system to boot" which i know is BS, as its just a NIC.
>
> I know the problem is stemming from the fact that somehow
> the system is still looking for the dne (deterministic
> network enhancer) protocol that the Direcway software
> must have installed, but I cant figure out how to remove
> it.
>
> I have tried to reisntall TCP/IP using the microsoft KB
> article that explains how on a domain controller, but
> that didnt work. I cant uninstall DNS or DHCP because
> when I do the setup program says a file is missing and it
> won't continue.
>
> I cannot just rebuild the server as they have 150+ user
> accounts and on top of all of this they are running MS
> Exchange server too (with all its wonderful complications)
>
> Is there a way to remove the deterministic network
> enhancer protocol or furthermore a way to reinstall the
> networking components somehow to remove reference to this
> DNE protocol that really does not exist.
>
> The other strange thing about this is that the DNE is not
> installed on any other Direcway system I have checked, so
> I am guessing it must be the earlier earthlink version of
> the software. (also I had a 3COM nic in there 905TX but
> I dont think it was that)
>
> It is Friday 9PM here and I have to have this up and
> running by Tuesday AM at the very latest. I have been
> pulling my hair out for 15+ hours on this now...
>
> Any suggestions would be EXCELLENT!!!
>
>
> Thank you!
>
>
> John Shoff
> jshoff@realitybytes.ca
 

TRENDING THREADS