Question Can't boot from uefi pen, no matter what. Secure boot disabled and uefi enabled. This happens. Help please

RealBeast

Titan
Moderator
I see that you've tried a number of things already from the reddit comments. What model is your motherboard? Are you using a backplate USB 2.0 and have tried several USB slots?

Secure boot disabled, is CSM and rapid boot off also?
 
Nov 4, 2020
8
0
10
0
I see that you've tried a number of things already from the reddit comments. What model is your motherboard? Are you using a backplate USB 2.0 and have tried several USB slots?

Secure boot disabled, is CSM and rapid boot off also?
MSI b450 Gaming Plus MAX , tried several usb and all the same, is it something to do with uefi bootloader on board? I have no idea how to fix this. Secure boot and csm disabled
 

RealBeast

Titan
Moderator
MSI b450 Gaming Plus MAX , tried several usb and all the same, is it something to do with uefi bootloader on board? I have no idea how to fix this. Secure boot and csm disabled
Have you disconnected all drives except the intended OS install target drive?

I would do that and then reset the CMOS, then recheck your secure boot and csm, then try again.
 
Nov 4, 2020
8
0
10
0
Have you disconnected all drives except the intended OS install target drive?

I would do that and then reset the CMOS, then recheck your secure boot and csm, then try again.
i will try that, btw the same happened to my laptop after trying to update to 20H2, ill try that in laptop since its the same problem, i'll keep you posted, thanks for helping
 
Nov 4, 2020
8
0
10
0
did you try boot override?
on the save & exit screen of bios, there is a choice called boot override.
Put USB in at boot
start PC and go into bios
if its a blank ssd, there shouldn't be anything in boot order yet
go to save & exit tab
pick boot override
Pick USB drive from list
PC will restart and boot from USB

page 52 here - https://download.msi.com/archive/mnu_exe/mb/E7B86v3.1.pdf
Tried that, same thing, I took a screenshot tho when choosing uefi interactive shell from boot override, maybe some clue here?
 

Colif

Win 10 Master
Moderator
you don't want to be in the efi shell. i can see it can see the USB and an nvme from that listing. that doesn't mean it can boot from them, just that it sees them

have you got latest bios?
 
Nov 4, 2020
8
0
10
0
you don't want to be in the efi shell. i can see it can see the USB and an nvme from that listing. that doesn't mean it can boot from them, just that it sees them

have you got latest bios?
Yes, i updated to the lastest bios trying to solve but the problem persisted. ubuntu on uefi boots fine from usb btw
 
Nov 4, 2020
8
0
10
0

Colif

Win 10 Master
Moderator
It shouldn't make any difference if its WIn 10 or UBUNTU on USB, it should still work??
scratches head??

have you tried making installer using media creation tool? it shouldn't make any difference but maybe?

Might need to contact MSI and ask them. It seems to me its more fundamental than just a few settings.

I assume you using a PC to make installer
 
Nov 4, 2020
8
0
10
0
It shouldn't make any difference if its WIn 10 or UBUNTU on USB, it should still work??
scratches head??

have you tried making installer using media creation tool? it shouldn't make any difference but maybe?

Might need to contact MSI and ask them. It seems to me its more fundamental than just a few settings.

I assume you using a PC to make installer
That was my reaction, ubuntu boots just fine from usb and i tried Clover EFI and it boots fine too, only default windows 10 efi from usb doesnt
 

ASK THE COMMUNITY

TRENDING THREADS