Question Can't Connect to Network: 5G, Only on My PC

May 29, 2020
1
0
10
0
Rewind a year ago, I was connected to my 5 GHz network without fail, and it ran incredibly smoothly. About a month ago, my PC refused to connect to my 5G network, and only to my 2G network. Not a huge deal, it still works, but it's INCREDIBLY SLOW. I looked into it a bit, and realized that maybe it's an issue with the WiFi card in my PC, a TPLink Archer 6E with the Latest Drivers.

Since I saw that, I bought a new network adapter, a Realtek 8812BU Wireless LAN 902.11ac USB NIC, which worked for about two weeks, and now we're back to the same problem. The 5G network appears in my Windows 10 network tab, I put the password in, it loads for a minute, then proceeds to say "Can't Connect to Network." with BOTH WiFi Adapters.

I have the oh so fabulous Spectrum Internet, and use their Default Router and Modem because my family is electronically illiterate and doesn't trust the upcoming Computer Science major with their technological needs. Since they don't trust me with having any idea what I'm doing, they also have the Router Login changed so I can't access it, although I know that may be the only option.

Like I said, the 2GHz network works perfectly fine, on all devices, but the 5GHz network works perfect on all devices other than my PC. I've made sure my drivers are updated for both network adapters, as well as tried to roll them back to old drivers.

If there's any more info you want/need, let me know and I'll try to answer as soon as possible. Thank you!
 

ASK THE COMMUNITY

TRENDING THREADS