Question Can't get any Internet access through the Ethernet Port... please help

Apr 22, 2021
1
0
10
0
Update: I can ping 8.8.8.8 without issues and disabling IPv6 does nothing. Don't know what this means in terms of the issue however, but clearly it can connect to and ping external sources and that IPv6 isn't the issue.

So just yesterday, the internet on my desktop stopped working seemingly randomly and since then I haven' been able to get any form of connection through it. The ethernet port works as it shows up and shows that it can establish a connection to my router, but all internet access is gone for no apparent reason. I've already tried replacing the cable, changing ports on my router, the usual on off trick for all my network devices and PC, releasing/renewing my IP, resetting network settings on Windows, I ran the trouble-shooter to no luck, I've tried using my laptop with the same cable and port on the router, reset the IPv4 and IPv6 reset.txt things, and I tried running the Intel Pro Ethernet program (or whatever its called) only to no luck as well other than to tell me it just cant get a connection to internet services, and at the moment I've plugged in a WiFi PCIe adapter and that works for connecting to the internet, but I need to return it ASAP so can't become permanent. I usually manage to figure out how to fix these things pretty quickly but somehow this one has just stumped me. And yes my internet is working just fine as every other device works perfectly with the internet. Thanks for any help in advance :)
 
Last edited:

ASK THE COMMUNITY