Question Can't get computer to boot

Chimera245

Honorable
Feb 25, 2015
8
0
10,510
0
I have a computer I use as a home server, (mostly running Minecraft servers, and storing everyone's music/pictures/documents/etc.) but lately, I can't get it to boot up.

It runs Windows 10 Pro off of a 500 GB SSD (C: ), and also has a 2 TB HDD (D: ).

I've run up and down google, trying to figure out what's wrong, and haven't really gotten any closer to fixing it.

Here's what I've tried, and what the computer tells me in response.

-Turn on computer
Reboot and select proper boot device or insert boot media in selected boot device and press a key
So I tried again with a Windows installation USB stick plugged in, and went to "repair my computer > troubleshoot"

-Startup Repair
Startup repair couldn't repair your PC. Press "advanced options" to try other options to repair your PC or "Shut down" to turn off your PC.
Then I tried things in the Command Prompt that google results suggested.

-Bootrec /fixmbr
The operation completed successfully.
-Bootrec /fixboot
Access is denied.
-Bootrec /rebuildBCD
Scanning all disks for Windows installations.
Please wait, since this may take a while...
Successfully scanned Windows installations.
Total identified Windows installations: 1
[1] C:Windows
Add installation to boot list? Yes(Y)/No(N)/All(A):Y
The requested system device cannot be found.

Here, I got lucky. Sometimes this shows 1 installation, sometimes it shows 0. I'm not sure what is changing between attempts.

-BCDboot C:\windows
Failure when attempting to copy boot files.
-Remove CMOS battery for 5 minutes
Reboot and select proper boot device or insert boot media in selected boot device and press a key
-fixmbr/fixboot/rebuildBCD again
same as before except now 0 windows installations identified.
I found a trick online to access files in recovery mode. I went to command prompt and started notepad.exe, went to "open", and used its file explorer interface to poke around.

-notepad.exe > open > stripped-down file explorer
Devices and drives (4)
Local disk(C: ) 432 GB free of 476 GB
HDD (D: ) 1.70 TB free of 1.81 TB
ESD-USB (E: ) 25.2 GB free of 29.2 GB
Boot (X: ) 506 MB free of 509 MB
The first time I did this, I noticed that the two drives had swapped letters. "Local Disk" (SSD) should have been C:, but was listed as D:, and "HDD" which should have been D:, was listed as C:.
I opened the case, and swapped the SATA cable connections on them, and since then, they've shown up with the correct drive letters. Also, immediately after swapping cables was the first time rebuildBCD showed 1 installation instead of 0, though it still goes back and forth between 0 and 1 seemingly at random.

Next I tried saving a text file through notepad, as a test of the SSD's writability, and it saved successfully.

Then I went back to the command prompt, and tried more "things google recommended that I barely understood".

-BCDedit /export c:\bcdbackup
The operation completed successfully.
-attrib c:\boot\bcd -h -r -s
Path not found - C:\boot
-diskpart > select disk 0 > list partition
partition # Type Size Offset
partition 1 Recovery 529 MB 1024 KB
Partition 2 System 99 MB 530 MB
Partition 3 Reserved 16 MB 629 MB
partition 4 Primary 476 GB 645 MB
At this point, supposedly I'm to select the partition with Windows on it, and "activate" it, or something, but I don't know how to tell which one has Windows. "System" sounded promising, but 99MB sounded really small for an operating system. "Reserved" would have been my next bet, but it's only 16. And since I don't really know exactly what I'm doing at this point, and didn't know if activating the wrong partition would result in something going wrong, so I stopped and decided to come ask people who know more about this stuff than me.

I considered re-installing Windows to see if that fixed it, but I could only "Upgrade while keeping files and settings" after booting up the current windows installation, which I can't get to happen right now, or install clean, and wipe everything, and I really wanna try to see if I can save the files on C: drive first, before doing something that drastic. (If it comes to that, though, I can just copy the files onto a flash drive via notepad's "open" menu, though it's gonna be a pain)
 
Last edited:

Chimera245

Honorable
Feb 25, 2015
8
0
10,510
0
Ok, new weird thing.

I backed up what I needed off C drive, and reinstalled Windows. Or tried to. It won't let me delete the existing partitions on C drive through the windows installer. I mean it'll "let" me, like the button can be clicked, but nothing happens as a result. I select a partition, click "delete", get an hourglass cursor for a few seconds, then the partition is still there.

I tried through the command prompt > diskpart > select disk 0 > clean, and it'll say "disk 0 successfully cleaned" and "List partition" will tell me there are no partitions to show, but once I restart the computer, the partitions come back. Both in the installer, and through "list partition" in command prompt.

I have no idea what's going on now. Has my SSD given out or something?
 

ASK THE COMMUNITY

TRENDING THREADS