Question Cant get RAM to perfom at guaranteed speed

Feb 22, 2019
5
0
10
0
Hello, I've recently upgraded my PC. Overclocked my CPU and everything is running good except RAM. I have Patriot Viper 4 DDR4 dual kit (2x4gb, 3000mhz ram), but I can't get them to work at 2933 or 3200, my motherboard is ASRock B450M Pro4 so it only allows these two options, CPU: Ryzzen 3 1200 oc to 3.8 ghz and 1.3V. I updated my BIOS and loaded XMP profile, it changes my ram voltages to 1.35v and my ram nominal voltage is 1.2v so I'm afraid to use 1.35v even tho it works with 2933mhz which I would prefer. What should I do? Can I change voltage to XMP's default which is 1.35v or should I stick to what RAM manufacturer says is nominal voltage for these rams? Right now I'm running my RAM at 2666mhz with 1.2v voltage and have 0 problems. However if I change frequency I either get BSOD or computer boots but there's no display just darkness.
 

Rogue Leader

Titan
Moderator
Ok next thing to do is to remove the overclock on your processor completely. Then set the ram up to run in XMP. Test it see how it works. Once you get that working you will need to re do your cpu overclock, and you may find the settings to be different.
 
Feb 22, 2019
5
0
10
0
Ok next thing to do is to remove the overclock on your processor completely. Then set the ram up to run in XMP. Test it see how it works. Once you get that working you will need to re do your cpu overclock, and you may find the settings to be different.
Did that and still same issue. Was messing around a bit with the settings today and 2933mhz speed at 1.25V worked and lasted longest when tested with AIDA (about 12 min) while other speeds and configurations didn't last no more than 5 min. Could I run 2933mhz with 1.25V even when testing with AIDA it says hardware failure detected after testing for 12 min?
 

Rogue Leader

Titan
Moderator
Did that and still same issue. Was messing around a bit with the settings today and 2933mhz speed at 1.25V worked and lasted longest when tested with AIDA (about 12 min) while other speeds and configurations didn't last no more than 5 min. Could I run 2933mhz with 1.25V even when testing with AIDA it says hardware failure detected after testing for 12 min?
If it fails after 12 minutes its NOT Stable, do not run that. Does 2933 work at 1.3v?

Is that ram kit on the QVL for the board, it may be that the timings and stuff just won't work with Ryzen and you may need a different kit.
 

ASK THE COMMUNITY

TRENDING THREADS