Question Can't get to post/so graphics/no cpu fan powerup

tommolloy

Honorable
Jan 1, 2015
8
0
10,510
0
Hi all,

I've build about 7 systems, and followed all the steps here: https://forums.tomshardware.com/threads/no-post-system-wont-boot-and-no-video-output-troubleshooting-checklist.1285536/. It's been a while since I've built, so thinking I'm missing something easy.

I'm trying to set up a mining rig, but system won't post. Have it as a breadboard right now. Tried with different PSU and RAM modules so it's not that. Thinking motherboard may be faulty.

USB keyboard and flash drive have lights on, so mobo is getting power. CPU fan doesn't spin at all. No graphic output to monitor. I tried connecting some troubleshooting speakers to the mobo, but either there's no sound or I'm doing it wrong. On a previous setup, the keyboard/PSU would turn on for .5s and keep resetting (maybe a short). No longer the case.

Mobo is ASRock H110 Pro BTC. CPU is a celeron with stock cooler. 4gb ram - just the standard stuff. GPU (RTX 3070) connected via a riser, with DP out to a monitor. SSD is blank; flash drive has an image of HiveOS.

Any help would be appreciated! I have 2 of everything since I'm building 2 rigs, so tomorrow I might try connecting everything to the other mobo.

Have the 24-pin ATX connected, 8-pin CPU power, power to the riser, power to the SSD, and then power to a couple auxilliary connectors on the mobo, per the mobo manual (for extra graphics cards).
 

ASK THE COMMUNITY

TRENDING THREADS