Question Can't see PC drives when connected via VPN

ackoman

Distinguished
Jan 13, 2009
71
2
18,535
0
Hi,

When I'm in my home network, I can access my PC's harddrives from my android mobile phone using ES File Explorer, using SMB. My PC is running Windows 10.

I would like to be able to also access these drives when I am away from my network, using an OpenVPN connection. Unfortunately, it does not seem to be working - the only device I seem to be able to connect to when using the VPN is a USB harddrive that is directly connected to my router, a Netgear Nighthawk X4S - I can connect to this using either FTP or SMB when on the VPN.

My router's internal IP address is 192.168.0.1 and my PC is 192.168.0.4
According to the OpenVPN android app, my mobile has a "private" IP 192.168.1.2

When connected via the VPN, I am able to access my router's admin page by going to 192.168.0.1, i.e. the VPN must be working, since I would normally only be able to get to the router's admin page using that address if I was actually on my home network.

Is there any reason why I can't see anything beyond the router and the harddrive connected directly to it when I am using the VPN? Are other users able to access the entire home network when connecting via VPN?

Thanks in advance for any help.

Ackoman
 

ackoman

Distinguished
Jan 13, 2009
71
2
18,535
0
Hello again,

I've just discovered that I can get it to work if I disable the Windows Firewall for Public Network.

Is there some setting that I can change that will allow me to still connect, whilst keeping the firewall on? I don't feel comfortable disabling the firewall.

Thanks
Ackoman
 
Gotcha. I bet you can make an exception in the firewall that will keep it on for everything else--I just don't know how. I usually shut off all the firewalling stuff since I run rebootrx and run my systems like toasters.
 

ackoman

Distinguished
Jan 13, 2009
71
2
18,535
0
Click on "Network and internet setting" on your wifi symbol, then click on "Change connection properties" Select Private
Great, thanks!

That seems to work now - although it now requires me to turn off the firewall for private networks, but I assume that is not considered to be a big deal, since I'm in control of who connects to it. Is that logic sound?
 

ASK THE COMMUNITY

TRENDING THREADS