Computer not booting

Feb 8, 2019
2
0
10
0
I have been reading guides and forum posts nonstop for the past 4 days and even took my computer to a local repair shop to have it diagnosed but I still don't have an answer, this forum has always been very helpful in the past with any questions I've had so I decided to finally post.

Long story short, I've had this computer for little over a year, it's been working fine except for the PSU dying on me about a year ago but it was some generic PSU so I didn't think much of it and replaced it with a EVGA 600 one and all went back to normal. Last Sunday I turned off my computer in the normal fashion however Monday afternoon when I get home from work it simply would not start. I thought again that it was the PSU so I disconnected everything and plugged it all back in and nothing, took out the motherboard and tried to "breadbox" it like some.guides said and still nothing so I bought a new PSU, a Corsair 750m and it still would not turn on no matter what, no fans nothing. I thought it was the power switch so I tried to manually short the power button and still nothing that's when I decided to take it to a repair shop to get it diagnosed and they had it for about a day and gave me an inconclusive answer saying it was probably the motherboard, so I went and bought a new one, an MSI MPG z390 and plugged everything back but now it turns on for a split second with the fans and LEDs but it shuts down immediately.
The only difference is that now the LED indicator on the mobo for the CPU turns on before shutting down.
It's an i7 7700.
All the fans are connected , thermal paste applied and fan secured in place.
I've read the troubleshooting guide and worked through it to my best but still nothing. I just don't know what to do, the CPU is about a year old and I understand they can die but I don't want to buy a new one and the issue not even be the CPU.
Also I have never overclocked this CPU and only use it for games that are not very heavy on it.
I'd appreciate any help I can get on this thanks.

My specs are
i7 7700
MSI MPG z390 mobo
MSI 1060 gpu
Corsair 750m PSU
Xpg 8gb ram x2
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts