Question Computer not fully turning on.

Jan 30, 2020
14
0
10
0
I910900k
Artic liquid freezer ii 360
Maximus apex xii mobo
Corsair rmx 850 power supply
Samsung evo plus 970 500 gb
4400mhz viper 16 8x2 ram
1070 ti
Define 7 case
It will light up the mobo. But won't power a monitor. No fans are spinning... I would like to figure out why its not working before I get a 3080 o.o please help!
 
Last edited:
Jan 30, 2020
14
0
10
0
I910900k
Artic liquid freezer ii 360
Maximus apex xii mobo
Corsair rmx 850 power supply
Samsung evo plus 970 500 gb
1070 ti
Define 7 case
It will light up the mobo. But won't power a monitor. No fans are spinning... I would like to figure out why its not working before I get a 3080 o.o please help!
Case powers on aswell
 
Jan 30, 2020
14
0
10
0
I fixed it and added the ram aswell. Keep in mind I've now since gotten it to boot yesterday, and can't get it to boot again... its doing the same thing. Mobo lights up. No fans. And nothing I plug in gets power.
I've taken ram out, and reset them in place. Same with power cables. And gfx card.
 

vov4ik_il

Notable
Mar 23, 2020
1,131
147
940
35
I would:
-Reset CMOS (take the silver round battery out or use the jumper next to it)
-Power it on and FIRST go to BIOS and disable XMP
-Get the newest BIOS flashed (also make sure the memory is on the QVL)
-Try enabling XMP with the newest BIOS, if it does the same thing again, get another random access memory set that is ON the QVL or use it w/o the XMP.
 

ASK THE COMMUNITY