[SOLVED] Computer turns on but doesnt display or turn off.

tylerjseverino

Prominent
Jun 2, 2018
16
0
510
0
I've just built this today and it has never turned on successfully.
GTX 1050 2gb
Ryzen 3200g
8gb 4x2 viper 2666 ram
B450M DS3H Gigabyte mobo
Any help will be appreciated
 
Website says it supports 2nd gen ryzen cpus so it should be compatible.
3200g is classified as a 3rd gen CPU when determining compatibility.
Does the website where you bought this from say "3rd generations support."
The led is more of a line of orange led with no labeling
Ah, thats just some aesthetic lighting.

Do your fans spin? Did you plug everything in properly?

https://forums.tomshardware.com/faq/no-post-system-wont-boot-and-no-video-output-troubleshooting-checklist.1575220/
Check this out.

I would suppose the BIOS may be the issue.
 

tylerjseverino

Prominent
Jun 2, 2018
16
0
510
0
s
Do you confirm with the seller that the motherboard has a BIOS compatable with the 3200g?

Did you plug monitor into GPU? Any lights on motherboard?
PSU model?
I dont know the model but the psu is a 500watt evga one and I've tried both mobo and graphics card hdmi.
When I hold the power button the mobo light blinks and the mobo light is orange
 

tylerjseverino

Prominent
Jun 2, 2018
16
0
510
0
That doesnt mean your board is compatable.

For example, your motherboard could have been on a warehouse shelf longer than someone who bought one elsewhere. So your board may have an incompatable bios but there board would work.
Website says it supports 2nd gen ryzen cpus so it should be compatible.
 
Website says it supports 2nd gen ryzen cpus so it should be compatible.
3200g is classified as a 3rd gen CPU when determining compatibility.
Does the website where you bought this from say "3rd generations support."
The led is more of a line of orange led with no labeling
Ah, thats just some aesthetic lighting.

Do your fans spin? Did you plug everything in properly?

https://forums.tomshardware.com/faq/no-post-system-wont-boot-and-no-video-output-troubleshooting-checklist.1575220/
Check this out.

I would suppose the BIOS may be the issue.
 

tylerjseverino

Prominent
Jun 2, 2018
16
0
510
0
3200g is classified as a 3rd gen CPU when determining compatibility.
Does the website where you bought this from say "3rd generations support."

Ah, thats just some aesthetic lighting.

Do your fans spin? Did you plug everything in properly?

https://forums.tomshardware.com/faq/no-post-system-wont-boot-and-no-video-output-troubleshooting-checklist.1575220/
Check this out.

I would suppose the BIOS may be the issue.
Also the usb ports dont output anything.
And if the bios is the problem how would I fix it?
I have no other am4 cpus
 

tylerjseverino

Prominent
Jun 2, 2018
16
0
510
0
And if the bios is the problem how would I fix it?
https://www.amd.com/en/support/kb/faq/pa-100
AMD will loan you an older Athlon 200GE in order to boot your system and update the BIOS for 3rd gen support.
This is free if you return the CPU, but this process can take awhile.
Yes every fan spins.
If the BIOS is incompatable I would expect fan spin, lights, and no image. I would also expect a CPU or possibly DRAM debug LED if your motherboard had them. Which is what you are seeing, so i would check out the link above.
 

ASK THE COMMUNITY

TRENDING THREADS