[SOLVED] Computer unstable and crashing after installing 3rd NVME

Nov 20, 2022
3
0
10
0
Hello, Im really hoping someone has some idea whats going on here.

I currently have 2 nvme drives in my system, both xpg blades, 1 with windows on it and a 2TB with my games on it.
I bought a samsung 980 pro yesterday and placed it in one of my other m2 slots on my motherboard. When i turned on my computer it sat black screen for almost 10 min. Finally when it got into windows, everything seemed fine, I partitioned it and got it ready to go and it was showing along side my other two ssds. I started up a game and after about 5 min it would crash. When i restart it sets on black screen with a white light on my motherboard and sometimes doesnt go into windows at all. When it does go into windows sometimes it acts weird and my windows login screen doesnt even look right, showing a generic blue backround at the password screen. The other half of the time when I log in, 5 seconds after i get a blue screen and have to restart.
When I disconnect the samsung 980 pro, everything goes back to normal and is 100% stable. And I have yet to install anything at all on the new m2
I have tried the other m2 slot and same thing

Im shocked installing this 3rd m2 could cause so many insane issues. Has anyone here had this issue?

My system is
Ryzen 7950x
Asus ROG Strix X670E-E
Gigabyte RTX 4090 OC
32 gigs of DDR5 Gkill 6000mhz ram
Seagate 1300 watt powersupply
Windows 11

Thank you in advance
 
Last edited:

Darkbreeze

Retired Mod
That BIOS version is three versions behind the current version which is 0805. I would highly recommend updating. Should be a very simple process since that board has BIOS flashback. But even the flash utility IN the BIOS is very simple as well.

I'd also HIGHLY recommend you get rid of Armory crate. I have yet to see a system with that on it that doesn't have some kind of problem AND it is very inaccurate about driver version information. Besides which it is pretty much NEVER a good idea to rely on any kind of automatic driver updating utility whether it is from the manufacturer or not, except in cases where it is the ONLY way as with some OEM prebuilt systems. You should always visit the product page for your motherboard, manually download and then manually install the latest driver version for your board for chipset, network adapters (LAN and WiFi when present) and audio controller. On AMD products it is sometimes a better option to get the chipset driver directly from the AMD website.

After updating the BIOS it may be a good idea to also do a hard reset to force the BIOS to reconfigure the CMOS hardware tables.

BIOS Hard Reset procedure

Power off the unit, switch the PSU off and unplug the PSU cord from either the wall or the power supply.

Remove the motherboard CMOS battery for about three to five minutes. In some cases it may be necessary to remove the graphics card to access the CMOS battery.

During that five minutes while the CMOS battery is out of the motherboard, press the power button on the case, continuously, for 15-30 seconds, in order to deplete any residual charge that might be present in the CMOS circuit. After the five minutes is up, reinstall the CMOS battery making sure to insert it with the correct side up just as it came out.

If you had to remove the graphics card you can now reinstall it, but remember to reconnect your power cables if there were any attached to it as well as your display cable.

Now, plug the power supply cable back in, switch the PSU back on and power up the system. It should display the POST screen and the options to enter CMOS/BIOS setup. Enter the bios setup program and reconfigure the boot settings for either the Windows boot manager or for legacy systems, the drive your OS is installed on if necessary.

Save settings and exit. If the system will POST and boot then you can move forward from there including going back into the bios and configuring any other custom settings you may need to configure such as Memory XMP, A-XMP or D.O.C.P profile settings, custom fan profile settings or other specific settings you may have previously had configured that were wiped out by resetting the CMOS.

In some cases it may be necessary when you go into the BIOS after a reset, to load the Optimal default or Default values and then save settings, to actually get the BIOS to fully reset and force recreation of the hardware tables.
 

Darkbreeze

Retired Mod
Seagate doesn't make power supplies. What is the actual model of your power supply? I'm guessing you meant to say Seasonic?

What is the currently installed motherboard BIOS version?

Do you have the Samsung Magician installed? If not, I would install it, at least long enough to use it to check for updated firmware for the 980 Pro.

I'd also make sure you have manually gone to the product page for your X670-E and downloaded the latest chipset, network controller and audio drivers, and installed them. Do not rely on the native Windows drivers. You can also get the chipset driver from the AMD website. That might actually be newer in a lot of cases.
 
Nov 20, 2022
3
0
10
0
Seagate doesn't make power supplies. What is the actual model of your power supply? I'm guessing you meant to say Seasonic?

What is the currently installed motherboard BIOS version?

Do you have the Samsung Magician installed? If not, I would install it, at least long enough to use it to check for updated firmware for the 980 Pro.

I'd also make sure you have manually gone to the product page for your X670-E and downloaded the latest chipset, network controller and audio drivers, and installed them. Do not rely on the native Windows drivers. You can also get the chipset driver from the AMD website. That might actually be newer in a lot of cases.
Yup sorry , it is a Seasonic.

And i just checked on Asus Armory, and all my drivers are up to date with current versions

And it looks like the bios is on version 0514, which is only about a month old.

Its a really strange problem, I wish i could get the new m2 to work before i just have had enough and return it.
 

Darkbreeze

Retired Mod
That BIOS version is three versions behind the current version which is 0805. I would highly recommend updating. Should be a very simple process since that board has BIOS flashback. But even the flash utility IN the BIOS is very simple as well.

I'd also HIGHLY recommend you get rid of Armory crate. I have yet to see a system with that on it that doesn't have some kind of problem AND it is very inaccurate about driver version information. Besides which it is pretty much NEVER a good idea to rely on any kind of automatic driver updating utility whether it is from the manufacturer or not, except in cases where it is the ONLY way as with some OEM prebuilt systems. You should always visit the product page for your motherboard, manually download and then manually install the latest driver version for your board for chipset, network adapters (LAN and WiFi when present) and audio controller. On AMD products it is sometimes a better option to get the chipset driver directly from the AMD website.

After updating the BIOS it may be a good idea to also do a hard reset to force the BIOS to reconfigure the CMOS hardware tables.

BIOS Hard Reset procedure

Power off the unit, switch the PSU off and unplug the PSU cord from either the wall or the power supply.

Remove the motherboard CMOS battery for about three to five minutes. In some cases it may be necessary to remove the graphics card to access the CMOS battery.

During that five minutes while the CMOS battery is out of the motherboard, press the power button on the case, continuously, for 15-30 seconds, in order to deplete any residual charge that might be present in the CMOS circuit. After the five minutes is up, reinstall the CMOS battery making sure to insert it with the correct side up just as it came out.

If you had to remove the graphics card you can now reinstall it, but remember to reconnect your power cables if there were any attached to it as well as your display cable.

Now, plug the power supply cable back in, switch the PSU back on and power up the system. It should display the POST screen and the options to enter CMOS/BIOS setup. Enter the bios setup program and reconfigure the boot settings for either the Windows boot manager or for legacy systems, the drive your OS is installed on if necessary.

Save settings and exit. If the system will POST and boot then you can move forward from there including going back into the bios and configuring any other custom settings you may need to configure such as Memory XMP, A-XMP or D.O.C.P profile settings, custom fan profile settings or other specific settings you may have previously had configured that were wiped out by resetting the CMOS.

In some cases it may be necessary when you go into the BIOS after a reset, to load the Optimal default or Default values and then save settings, to actually get the BIOS to fully reset and force recreation of the hardware tables.
 
Nov 20, 2022
3
0
10
0
So i took the steps you told me to take minus the last part regarding the BIOS hard reset.

It worked like a charm!! Thank you very much for taking the time out of your day to help me. I had no idea that having that version of the bios could make adding a 3rd SSD such a nightmare and create so many problems!!

Ill keep a eye on things and if any problems pop up I may end up posting them here. Got rid of Armory too
 

Darkbreeze

Retired Mod
Nice man. Glad it was helpful. We are always here although if it's a different issue it's recommended to start a new thread and you can always shoot me a PM with the link to that thread and I'll be happy to chime in if that should happen to occur at some point. Good luck to you.
 

ASK THE COMMUNITY