Question Connecting an extra router - problem with chromecast

__Alex__

Commendable
Feb 21, 2019
24
0
1,510
0
Hello,

I have a fiber router with wifi and TV. It cannot reach some of the devices in a remote room, and thus I have installed an extra router from TP link in that room. So, with a RJ45 cable the extra router is connected to the main fiber router. I would like these two routers to "define" the same network. So, when I am walking around with my phone, it should take the signal from router that is closest and I do not have to change network every time. Basically, for me it is the same network, and the extra router is there simply because the remote room did not have a strong signal otherwise.
I thought that I managed to do this by myself until I found out that I some of my chromecast devices were not available on my phone. And then I could see what the logic was: if a TV connects to one router, while my phone is connected to another router (even though the network name is the same), then the TV will not be on the list of available devices when using Chromecast. How can I solve this problem? I am far from being an expert in installing wireless networks.

So, these are the steps when installing the new router in the remote room:

First it asks me whether this router is: Wireless Router, WISP, Access Point, Range Extender.
I have chosen Access Point.

Then it asks me to give it a name and a password. I type exactly the same name and password that my main fiber router has.

Then it asks me to choose between Static IP or DHCP. If I choose Static, then I type the IP address myself. If I choose DHCP, then I cannot choose the IP address. In the bottom I can also enable or disable DHCP server. What are the correct settings here?

Thank you in advance!
 

kanewolf

Titan
Moderator
Hello,

I have a fiber router with wifi and TV. It cannot reach some of the devices in a remote room, and thus I have installed an extra router from TP link in that room. So, with a RJ45 cable the extra router is connected to the main fiber router. I would like these two routers to "define" the same network. So, when I am walking around with my phone, it should take the signal from router that is closest and I do not have to change network every time. Basically, for me it is the same network, and the extra router is there simply because the remote room did not have a strong signal otherwise.
I thought that I managed to do this by myself until I found out that I some of my chromecast devices were not available on my phone. And then I could see what the logic was: if a TV connects to one router, while my phone is connected to another router (even though the network name is the same), then the TV will not be on the list of available devices when using Chromecast. How can I solve this problem? I am far from being an expert in installing wireless networks.

So, these are the steps when installing the new router in the remote room:

First it asks me whether this router is: Wireless Router, WISP, Access Point, Range Extender.
I have chosen Access Point.

Then it asks me to give it a name and a password. I type exactly the same name and password that my main fiber router has.

Then it asks me to choose between Static IP or DHCP. If I choose Static, then I type the IP address myself. If I choose DHCP, then I cannot choose the IP address. In the bottom I can also enable or disable DHCP server. What are the correct settings here?

Thank you in advance!
Generally when you configure a router as an AP (access point), you want to give it a static IP address so that you can easily access the config pages.
You need to pick an IP address that is outside the DHCP range on your main fiber router. I use large IP addresses for my static IPs > 200 for example. If you do that, then you need to adjust the range of IP addresses managed by the DHCP server in the fiber router so that it stops at 199.
There is no guarantee that your phone will choose the closer AP. The phone (or tablet, or laptop) chooses what WIFI signal. If you can TURN DOWN the radio strength on your WIFI sources (router and AP) then you have a better chance of your phone roaming. There is also no guarantee that your phone won't drop or glitch when moving from WIFI to WIFI.
 
Reactions: __Alex__

__Alex__

Commendable
Feb 21, 2019
24
0
1,510
0
Generally when you configure a router as an AP (access point), you want to give it a static IP address so that you can easily access the config pages.
You need to pick an IP address that is outside the DHCP range on your main fiber router. I use large IP addresses for my static IPs > 200 for example. If you do that, then you need to adjust the range of IP addresses managed by the DHCP server in the fiber router so that it stops at 199.
There is no guarantee that your phone will choose the closer AP. The phone (or tablet, or laptop) chooses what WIFI signal. If you can TURN DOWN the radio strength on your WIFI sources (router and AP) then you have a better chance of your phone roaming. There is also no guarantee that your phone won't drop or glitch when moving from WIFI to WIFI.

Thank you! It seems to work.

I have chosen this setup:
  • Access Point mode
  • same name and password as the fiber router
  • Static IP: then I typed 200. and then some 0 and 1 (randomly).
  • DHCP server: disabled

If you see that something is wrong, please let me know. Thanks!
 

kanewolf

Titan
Moderator
Thank you! It seems to work.

I have chosen this setup:
  • Access Point mode
  • same name and password as the fiber router
  • Static IP: then I typed 200. and then some 0 and 1 (randomly).
  • DHCP server: disabled
If you see that something is wrong, please let me know. Thanks!
You just need to go back to the fiber router and verify that 20x is outside the range that the DHCP server on the fiber router is allocating.
 

ASK THE COMMUNITY

TRENDING THREADS