CPU debug led when power on leads to burnt cpu/cpu socket on motherboard

Dec 19, 2021
1
0
10
0
Hello! I'm new to pc building and I just built(tried to) my first PC yesterday. I started building yesterday and when I got to the CPU, things got a bit weird.

(1)When I pull up the retention arm, it won't go all the way up. There's something resisting it to go up and I was afraid to break something by forcing it to go up the way it should be as I've seen on videos, I just left it as is and then moved on to placing the cpu. After placing the cpu, I gave it a little bit of nudge to make sure it is well seated then pushed back the retention arm in place. (2)After doing that, as soon as I lifted my finger, I heard a single click and nudged the cpu again with the retention arm down, and saw it's still secured in place.

Retention arm won't go all the way up View: https://imgur.com/a/3TNJNze


After that, I thought everything should be okay and then continued to install the cpu cooler up to finishing the build.

So I finished plugging in everything, I was ready to boot up my freshly built pc. I connected my pc to the monitor via HDMI cord, plugged in both the pc and monitor, pressed the I on the power supply and then pressed the power button on front panel of my pc. The case fans were spinning with the lights, the ram sticks were on, lighting up, cpu fan also spinning, but no display on my monitor. After a few seconds, the pc shut down on its own. I pressed the power button again to see what's up, then everything went up again, fans spinning, RGBs lightng up but still no display then I took a closer look to my motherboard and saw the cpu EZ debug led on solid white, this time the pc didn't shut down after a few seconds so I held the power button to shut it down. At this point I was like "damn, maybe I should do a BIOS update even though my mobo box had the ryzen 5000 ready sticker on it" but at the back of my mind, I remembered the 2 points I mentioned earlier.

So I went on to disassemble and investigate the cpu. I screwed off the cpu fan and then pulled it up, then it went off the with cpu glued on it. I saw some slight burn on my cpu and looked at the cpu slot on my motherboard and saw some burnt holes at the same area as my cpu. I think I toasted my cpu.

Burnt CPU View: https://imgur.com/a/W4BHS1k


Burnt CPU slot View: https://imgur.com/a/Grc8k3S


After disassembling and removing the cpu, I pulled up the retention arm up and it still won't go all the way up. This time I used abit more force and now it goes up like normal.

Are both my cpu and motherboard dead? Any idea where I went wrong? I think it should be around the 2 points I mentioned but is this covered by warranty? Thanks in advance.

PC Specs:

CPU: Ryzen 5 5600g
Motherboard: MSI B550m pro VDH wifi
ram: PNY XLR8 DDR4 RGB 3600MHZ 16GB (2x8) CL18
PSU: MSI MAG A650GF Full Modular
storage: Samsung 980 500GB (non pro)
 

Ralston18

Titan
Moderator
Unfortunately it appears that both motherboard and CPU have been destroyed.

Unlikely to be covered by warranty due to possible user error.

Probably because the CPU was not correctly aligned to the socket.

Moving your post to CPU's - hopefully there will be some additional ideas and comments about what happened.
 

ASK THE COMMUNITY