Question CPU usage dropping but temps and voltages are fine causing game to drop frames

Oct 11, 2020
4
0
10
0
I have a I9 9900k with a MSI Z390 MEG ACE custom liquid-cooled with a EKWK Monoblock on the MB so my temps are always perfect on my cpu and motherboard MOSFETs. When I am playing games like for example rocket league my cpu is usually at around 20% but randomly will drop to like 8% and cause my game to drop frames but I am watching everything on the performance monitor on dragon center and no voltage drops I took of my OC and just have it on the stock clock and the cpu frequency stays at 4.8mhz and does not go under at all. This also does the same thing on call of duty I dont see my temps go above 62C when playing cod but the same thing happens you see the cpu usage drop randomly and the frames drop with it. I have all my Windows, Nvidia drivers, MB bios all up to date. I have had so many problems with the motherboard already had to send my first one back because of constant blue screens for no reason with no games running.

Please let me know if you have any ideas what it could be
 

puw2

Reputable
Sep 25, 2017
503
104
5,290
60
I have a I9 9900k with a MSI Z390 MEG ACE custom liquid-cooled with a EKWK Monoblock on the MB so my temps are always perfect on my cpu and motherboard MOSFETs. When I am playing games like for example rocket league my cpu is usually at around 20% but randomly will drop to like 8% and cause my game to drop frames but I am watching everything on the performance monitor on dragon center and no voltage drops I took of my OC and just have it on the stock clock and the cpu frequency stays at 4.8mhz and does not go under at all. This also does the same thing on call of duty I dont see my temps go above 62C when playing cod but the same thing happens you see the cpu usage drop randomly and the frames drop with it. I have all my Windows, Nvidia drivers, MB bios all up to date. I have had so many problems with the motherboard already had to send my first one back because of constant blue screens for no reason with no games running.

Please let me know if you have any ideas what it could be
What about your PSU? Model and age?
 
Oct 11, 2020
4
0
10
0
What GPU are you using? That's a very important component when addressing FPS issues.
I am using a RTX 2070 EVGA XC Ultra that is also liquid-cooled so the temps are completely fine when playing and the clock speed isn't moving at all so I'm pretty sure that's not causing the problem.
 

rickypicky5

Notable
Sep 9, 2019
677
81
1,040
44
My guess is the motherboard. When you sent your first one back are you sure they gave you a new one in return? Or did they 'fix' the original? Refurb? That make/model motherboard is supposed to have a very good power delivery system, but...
 
Oct 11, 2020
4
0
10
0
My guess is the motherboard. When you sent your first one back are you sure they gave you a new one in return? Or did they 'fix' the original? Refurb? That make/model motherboard is supposed to have a very good power delivery system, but...
Yeah that's what I was thinking too but I switched out to my other asus z390 prime motherboard yesterday formated all my ssds and put new windows on the pc, and still having the same exact problem with the i9 cpu usage dropping while gaming but times are completely fine and voltages look fine. I have no OC I have factory setting on the motherboard bios. At this point I dont know what it is either cpu or psu.
 

ASK THE COMMUNITY

TRENDING THREADS