Question Critical process died + reboot and select a proper boot device

Aug 27, 2019
16
0
10
0
Hello,
I had a problem with my pc since I bought it and built it, I randomly get bsod critical process died and then my pc restarts by itself and i get a black screen that says “reboot and choose a proper boot device” , i tried many software troubleshootings , but non worked . for instance , i ran a sfc scannow , and all three DISMs -scan health , restore health and check health. I also restored the system several times, i checked if my cpu fan isn’t work but it seemed fine and I downloaded a temperature tracker and my cpu’s temp seemed fine also, and finally I’ve formatted my disk and downloaded a clean windows again . I started thinking that it might be a hardware issue but i don’t Know where to start so plz help.

These are the parts that i used for my pc:

Msi z370 gaming plus .
Intel core i5 8600k.
G.skills 16 gb ddr4 3200 ram.
Nzxt h500i case.
Rosewill hive 650W
Nzxt kraken cpu cooler.
Adata 240gbs ssd.
2tb wd blue hdd.
 

Colif

Win 10 Master
Moderator
if my pc couldn't find the boot drive after a restart I would be checking drive health. Critical process died affects a range of windows drivers that if they crash, take windows with it. So its not simple matter to work out what crashed without a file name.

try running chkdsk on the ssd
open command prompt (admin)
type chkdsk c: /f and press enter
2 paragraphs will pop up, type Y and press enter to agree to running at startup, restart PC so chkdsk can run
you can run it on hdd as well, difference is what switches you add after
HDD: chkdsk c: /f /r

You might want to run this on ssd - https://www.adata.com/us/ss/software-6/

If its just random., set this up to catch next one
Can you follow option one on the following link - here - and then do this step below: Small memory dumps - Have Windows Create a Small Memory Dump (Minidump) on BSOD - that creates a file in c windows/minidump after the next BSOD

copy that file to documents
upload the copy from documents to a file sharing web site, and share the link in your thread so we can help fix the problem

Do you have latest BIOS on motherboard?
 

ASK THE COMMUNITY

TRENDING THREADS