[SOLVED] D.O.C.P. vs Q fan control in UEFI

gn842a

Respectable
Oct 10, 2016
621
43
2,040
5
ASUS Prime X470 with Ryzen 5 2600 and 16 gigs DD4 RAM

I recently used Q fan control to determine its own automatic settings on my new build. I also picked the occasion to choose the option for DOCP because it seemed like the thing to do.

So it seems that:

  1. I can have the fans on default and select DOCP
  2. I can have the fans do the automatic self balancing thing and ignore the DOCP option
  3. But I must NOT have DOCP selected AND have the fans self balancing. The pc box emits horrid noises (maybe the DVD trying to open) and does a long beep followed by two shorts which according to the manual means I have something wrong with my RAM which however does not appear to have anything wrong with it.
And I don't have any problems as long as I stick one coourse (the Q fan auto settings) or the other (DOCP) but not both.

I'm inclined to let the machine control the fans and ignore DOCP whose ultimate function--imitating XML?--isn't even clear to me.

Comments and wisdom appreciated.

Greg N
 
Try updating the BIOS. DOCP is like XMP - it overclocks your memory to what it's advertised speed is, which is essential for Ryzen CPU's. If BIOS update doesn't fix it, you can just take the manual route - turn on Q-fan control, and manually set your RAM to its advertised speed, let DOCP be turned off. If your memory is, for example, rated at 2666 MHz, you can manually set it to that speed(and usually even higher) in the BIOS.
 

gn842a

Respectable
Oct 10, 2016
621
43
2,040
5
Try updating the BIOS. DOCP is like XMP - it overclocks your memory to what it's advertised speed is, which is essential for Ryzen CPU's. If BIOS update doesn't fix it, you can just take the manual route - turn on Q-fan control, and manually set your RAM to its advertised speed, let DOCP be turned off. If your memory is, for example, rated at 2666 MHz, you can manually set it to that speed(and usually even higher) in the BIOS.
Try updating the BIOS. DOCP is like XMP - it overclocks your memory to what it's advertised speed is, which is essential for Ryzen CPU's. If BIOS update doesn't fix it, you can just take the manual route - turn on Q-fan control, and manually set your RAM to its advertised speed, let DOCP be turned off. If your memory is, for example, rated at 2666 MHz, you can manually set it to that speed(and usually even higher) in the BIOS.
The most recent posted bios update is called Prime-X470-Pro-ASUS-5007.CAP and it is a world of hurt. In my last encounter with it, it forced me to open up a onedrive account and rename my computer.

I'm not going near any .CAP extension in the future....

I will try manually entering the RAM speeds.

thank you. --Greg N
 

gn842a

Respectable
Oct 10, 2016
621
43
2,040
5
This guy has the same problem and the same hardware. The last post reads that per the manual RAM has to be in the A2 B2 slots. I think this is potentially the problem. I wasn't having these issues a few days ago.

I installed 2 x 8 gigs RAM in A2 B2 following instructions, and had no issues.

However, when the hardware arrived that would let me install my noctua on the mobo, I moved the RAM to A1 B1. My reason for doing so was to make sure that the hefty Noctua installation would still leave enough room for the RAM. The A1 slot is closest to the cpu fan and if its presence prevented the Noctua install I would have just continued using the OEM cpu fan.

When I was done installing the Noctua I just left the RAM in place. I figured it wouldn't matter--and in any case I did and do have two more sticks o' RAM on order to bring the total up to 4 x 8 gigs or 32 gigs total. In fact, this extra RAM is supposed to arrive today.

So to conclude it seems likely that this problem will go away when I install the RAM this afternoon.

Is this a known thing? I mean, the every-other-slot thing is pretty well known, but is it a known thing that A1 B1 is a problem if the manual says A2 B2 when not using a full compliment of RAM?

thanks,

Greg N
 

gn842a

Respectable
Oct 10, 2016
621
43
2,040
5
Well I'd like to give the best answer to the guy in the link I provided in post #4, the guy way down at the end who said it was a problem of using A1 B1 not A2 B2 for the two sticks of 8 gb RAM. But that was not my thread. The BIOS was a good idea.

I suspect some people just install the two sticks A1 B1 because for ages (if I am right) it didn't matter. I did however RTFM and saw the advice but they didn't make it look like a bad thing if you didn't. But in fact, even though the system is fine with 2 8gb sticks of RAM, it is very particular about how they are installed.

And as I mentioned the only reason I deviated from the A2 B2 config was I wanted to see how the RAM worked in terms of leaving space for the fan/heat sink. I didn't realize that by leaving them there I would get into trouble.

So I aware best answer not to myself but to the guy in the other thread.

Greg N
 

ASK THE COMMUNITY

TRENDING THREADS