Question Dell Alien Alpha Machine showing blinking orange light?

jay32267

Glorious
Hello all. When the power button is pressed the light shows green but then shows an orange blinking light and does not show anything on the attached monitor, help please? This is the unit:

https://www.dell.com/us/dfh/p/alienware-alpha-r2-desktop/pd

my internet searches for this issue shows a bad CMOS battery but I am not sure so decided to check here first, thanks.
I'm just going by memory here....but I seem to recall with a Dell....that being power supply.
...and I seem to recall doing a number of these....and I seem to recall they were Dell GX260s and GX280s.
You can try the CMOS battery.
I'd also google it....but I'm recalling "power supply".
 

jay32267

Glorious
Hello all. When the power button is pressed the light shows green but then shows an orange blinking light and does not show anything on the attached monitor, help please? This is the unit:

https://www.dell.com/us/dfh/p/alienware-alpha-r2-desktop/pd

my internet searches for this issue shows a bad CMOS battery but I am not sure so decided to check here first, thanks.
I also just found this for a Dell Dimension.....

"A new battery is a cheap thing to try. But, typically a blinking amber power button is a sign that there's an issue with the power supply. See the manual "
 
Aug 25, 2020
9
3
15
0
Hello all. When the power button is pressed the light shows green but then shows an orange blinking light and does not show anything on the attached monitor, help please? This is the unit:

https://www.dell.com/us/dfh/p/alienware-alpha-r2-desktop/pd

my internet searches for this issue shows a bad CMOS battery but I am not sure so decided to check here first, thanks.
Try long press of Power Button (15 sec)

In past i faced the same issue.

If not resolved then replace the battery is the last option.
 

mikehende

Distinguished
Mar 20, 2013
148
0
18,690
1
You mean press for 15 seconds without the power cord attached then connect the power cord? If I press and hold with the cord connected, it powers on then shuts down after a few seconds then after 15 seconds I release then power on again, same deal.
 
Aug 25, 2020
9
3
15
0
You mean press for 15 seconds without the power cord attached then connect the power cord? If I press and hold with the cord connected, it powers on then shuts down after a few seconds then after 15 seconds I release then power on again, same deal.
Attach the power cord.

Press Power Button for 15 Seconds

Release the Power Button

Press the Power Button ONCE
 
Reactions: mikehende
Aug 25, 2020
9
3
15
0
Reactions: mikehende

mikehende

Distinguished
Mar 20, 2013
148
0
18,690
1
Got the one from eBay yesterday but it has a total different connector so will order one from Dell now. At any rate, we were able to scrap the unit to get to the battery, thanks.
 

ASK THE COMMUNITY

TRENDING THREADS