Question Desktop computer loses signal to monitor but pc still runs.

Jun 13, 2022
4
0
10
0
Firstly, I have seen similar threads to this but have not found a solution.

Problem:
Desktop computer will turn on but lose display to monitor at inconsistent intervals. Sound still works and I can still click applications but there is no display. I cannot replicate this error and sometimes the pc won’t even make it too the desktop. Please note this happens under no load and inconsistently.

Solutions Tried:
  • Taken into PB tech and have had it looked at 4 times. Everytime it is in the shop it runs perfectly for them for multiple days. We have tested each part one by one in a different machine with no errors.
  • DDU clean of all drivers
  • reset updated bios
  • new cords (power, hdmi, DP etc)
  • no perfs plugged in (Mouse and keyboard)
  • clean windows install
  • New monitor
  • changed Hz on monitor back down to 60
  • new Psu
  • different plugs in house
  • ram sticks alternated (or one stick at a time in all 4 ports)
Theory:
(House power) We live in an old villa and we assume the house is leaking earthing causing the GPU to shut off as a safety feature

PC Specs: (Please note we have no internal graphics on MB/CPU

AS Rock B450M mother board
Ryzen 7 3700x cpu
Gigabyte RTX 3060 super
2x Hyper X DDR4 16gb ram
256SSD clean windows 11 install
1tb HDD clean
EV3A 650w Gold PSU
4x case fans with adequate cooling

The PC is a year old and has worked perfectly it’s entire life. We moved into this house and 2months later it started black screening.
 
Last edited:
Firstly, I have seen similar threads to this but have not found a solution.

Problem:
Desktop computer will turn on but lose display to monitor at inconsistent intervals. Sound still works and I can still click applications but there is no display. I cannot replicate this error and sometimes the pc won’t even make it too the desktop. Please note this happens under no load and inconsistently.

Solutions Tried:
  • Taken into PB tech and have had it looked at 4 times. Everytime it is in the shop it runs perfectly for them for multiple days. We have tested each part one by one in a different machine with no errors.
  • DDU clean of all drivers
  • reset updated bios
  • new cords (power, hdmi, DP etc)
  • no perfs plugged in (Mouse and keyboard)
  • clean windows install
  • New monitor
  • changed Hz on monitor back down to 60
  • new Psu
  • different plugs in house
  • ram sticks alternated (or one stick at a time in all 4 ports)
Theory:
(House power) We live in an old villa and we assume the house is leaking earthing causing the GPU to shut off as a safety feature

PC Specs: (Please note we have no internal graphics on MB/CPU

AS Rock B450M mother board
Ryzen 7 3700x cpu
Gigabyte RTX 3060 super
2x Hyper X DDR4 16gb ram
256SSD clean windows 11 install
1tb HDD clean
EV3A 650w Gold PSU
4x case fans with adequate cooling

The PC is a year old and has worked perfectly it’s entire life. We moved into this house and 2months later it started black screening.
Just to check is the black screen issue occurring whilst using the machine, or whilst idle? Also what type of connection are you using to your screen?

I have run into an issue with Display Port based screens where the screen won't wake up from idle despite the machine working fine. If this is the problem then this is likely an issue with the monitor rather than the machine itself - the solution is to fully power down (i.e. unplug from the mains) the monitor for 30 seconds or so, then plug it back in and it should reconnect.

If you think the cause of the problem is the stability of the power supply in your house then you can isolate the machine (and monitor potentially) from the mains using a UPS power supply which goes between your system and the mains supply. These typically offer a short battery backup facility and also provide voltage regulation and surge protection to ensure any noise on the main circuit doesn't make it to the computer.
 
Jun 13, 2022
4
0
10
0
Just to check is the black screen issue occurring whilst using the machine, or whilst idle? Also what type of connection are you using to your screen?

I have run into an issue with Display Port based screens where the screen won't wake up from idle despite the machine working fine. If this is the problem then this is likely an issue with the monitor rather than the machine itself - the solution is to fully power down (i.e. unplug from the mains) the monitor for 30 seconds or so, then plug it back in and it should reconnect.

If you think the cause of the problem is the stability of the power supply in your house then you can isolate the machine (and monitor potentially) from the mains using a UPS power supply which goes between your system and the mains supply. These typically offer a short battery backup facility and also provide voltage regulation and surge protection to ensure any noise on the main circuit doesn't make it to the computer.
Hi thanks for your response.

black screens happens with use. Sometimes it won’t make it past the BIOS/startup. Sometimes I can sit on the desktop for 2minutes, sometimes I can use the pc for a whole day before it black screens.
One thing to note is when it does black screen; usually the gigabyte logo on the GPU stops displaying RGB colour and has a dim red light behind it.
 

ASK THE COMMUNITY

TRENDING THREADS